locked
SQL Server 2008 Will Not Allow Me To CREATE a LOGIN from the Security Folder RRS feed

  • Question

  • I have Windows 7 Pro(x64), SQL Server 2008 developer edition, IIS 7.5
    Trying to create a login for IIS APPPOOL\ASP.NET v4.0 from
    SSMS->Security->Logins
    I am not getting the "Login failed for user IIS APPPOOL\ASP.NET v4.0"

    I am getting this error:

    Create failed for Login "IIS APPPOOL\ASP.NET v4.0" (Microsoft.SqlServer.Smo)
    Windows NT user or group IIS APPPOOL\ASP.NET v4.0 not found. Check the name again.
    Microsoft SQL Server, Error 15401

    Correct me if I am wrong, but is this not a totally differnt error/issue than
    "Login failed for user IIS APPPOOL\ASP.NET v4.0"

    Any help or ideas would be greatly appreciated. Thanks!
    Saturday, August 27, 2011 9:43 PM

All replies

  • What if you run CREATE LOGIN [IIS APPPOOL]\[ASP.NET v4.0]............
    Best Regards, Uri Dimant SQL Server MVP http://dimantdatabasesolutions.blogspot.com/ http://sqlblog.com/blogs/uri_dimant/
    Sunday, August 28, 2011 8:17 AM
  • I am getting this error:

    Create failed for Login "IIS APPPOOL\ASP.NET v4.0" (Microsoft.SqlServer.Smo)
    Windows NT user or group IIS APPPOOL\ASP.NET v4.0 not found. Check the name again.
    Microsoft SQL Server, Error 15401


    Are you shure you have such a Windows User located on your computer?
    Can you check it in your [local users] in computer administration...

    Basically 99.9% of error messages from sql server are not sql server reasons :D

     


    Uwe Ricken

    MCITP Database Administrator 2005
    MCITP Database Administrator 2008
    MCITS Microsoft SQL Server 2008, Database Development

    db Berater GmbH
    http://www-db-berater.de
    Sunday, August 28, 2011 10:46 AM
  • I have laptop with identical software as my desktop.  For an experiment, I set up the instructions from the book I am reading, and it installed without any issues.  

    I have tried many things, including  CREATE LOGIN [IIS APPPOOL]\[ASP.NET v4.0], as Uri mentioned above, but must be overlooking something (I am new to IIS, and SQL 2008).  I do not understand why the procedures/instructions installed without a glitch on my laptop but will not on my desktop.  I need to get it installed on my desktop for many reasons.

    Uwe,  How do you add IIS APPPOOL/ASP.NET v4.0  as a LOCAL USER?  I think I tried that and it said invalid user or invalid characters or something like that. All I did on my laptop was run the scripts from the book set up and it added IIS APPPOOL\ASP.NET v4.0 automatiacally as a USER in the database I set up for the book.

    Here are the two Steps to set up the book:

    1. Step 1: Run the Script to create the database called "Halloween"   (This step works fine on both my laptop and desktop)

    2. Step 2: Run this script:

    sp_grantlogin 'IIS APPPOOL\ASP.NET v4.0'

    GO

    USE Halloween

    GO

    sp_grantlogin 'IIS APPPOOL\ASP.NET v4.0'

    GO

    sp_grantdbaccess 'IIS APPPOOL\ASP.NET v4.0'

    GO

    sp_addrolemember 'db_owner', 'IIS APPPOOL\ASP.NET v4.0'

    GO

    EXIT

    "When I ran this script on my Laptop it worked like a champ!!  No problems at all.  the script created a USER called 'IIS APPPOOL\ASP.NET v4.0'  automatically in the Halloween database, but when I try this same process on my desktop.  I get  error:

    "Windows NT user or group 'IIS APPPOOL\ASP.NET v4.0' not found. Check the name again.

     

    Thanks,

    Dave

     

     


    Sunday, August 28, 2011 2:54 PM
  • Hallo Dave,

    did you check this: http://www.gotknowhow.com/articles/fix-login-failed-for-user-iis-apppool-aspnet-v4-error-iis7


    Uwe Ricken

    MCITP Database Administrator 2005
    MCITP Database Administrator 2008
    MCITS Microsoft SQL Server 2008, Database Development

    db Berater GmbH
    http://www-db-berater.de
    Sunday, August 28, 2011 3:00 PM
  • Yes I have.  Thanks. -)

    "I do not have a Website" (Yet, just trying to set up the book)   But I did follow the instructions by right clicking on the Application Pool "ASP.NET v4.0"

    Ran the script again and get the same error "IIS APPPOOL\ASP.NET v4.0" not found" Check the name again.

    Thanks,

    Dave


    Sunday, August 28, 2011 3:13 PM
  • Hi Dave,

    You may have a look at this KB article for troubleshooting this issue: How to troubleshoot error 15401.

    Hope this helps.


    Best Regards,
    Stephanie Lv

    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.
    Tuesday, August 30, 2011 12:13 PM
  • Stephanie,

    Nothing applied in the article,  but the "BUILTIN" ideas.  I tried BUILTIN\IIS APPPOOL   and BUILTIN\ASP.NET v4.0 and got the same "CREATE FAILED" error.

    SQL Server 2008 is not letting me "CREATE" logins.  My laptop has virtually the same set up, and I can "CREATE" logins from the security folder all day with my laptop.

    As I mentioned above, all I did for my laptop setup was Create the Halloween Database,  and ran the scripts above.  It automatically created the IIS APPPOOL\ASP.NET v4.0 login.  I know I could just use my laptop for the book and move on, but I really would like to find out the root cause of why it is not working on my desktop.

    Thanks,

    Dave

    Wednesday, August 31, 2011 2:11 AM
  • Great Man, It worked for me thanks a million...
    Thursday, October 13, 2011 10:48 PM