locked
Could not establish trust relationship for the SSL/TLS secure channel RRS feed

  • Question

  •  

    Hi,

    I am working on sql server reporting services 2005 , i got this error while deploying a report

    Error 1 The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. C:\Temp\NotificationReport\db.rds 0 0 

    NB: i checked IIS no ssl required on all sites.

    Any Help ?

    Thanks

    Tarek Ghazali

    SQL Server MVP

    • Moved by Greg Y Tuesday, September 1, 2009 10:22 PM wrong forum (From:SQL Server Replication)
    Wednesday, February 22, 2006 4:22 PM

Answers

  • Hi,

    I solved the problem :

    in start-->program files-->microsoft sql server--> configurtion tools-->

    reporting server configuration.

    in report server virtual directory --> uncheck the require secure socket layer (ssl) connections--> press apply

     

    :)

    Thanks,

    Tarek Ghazali

    SQL Server MVP

    Monday, February 27, 2006 1:15 PM

All replies

  • Hi,

    I solved the problem :

    in start-->program files-->microsoft sql server--> configurtion tools-->

    reporting server configuration.

    in report server virtual directory --> uncheck the require secure socket layer (ssl) connections--> press apply

     

    :)

    Thanks,

    Tarek Ghazali

    SQL Server MVP

    Monday, February 27, 2006 1:15 PM
  • If you want to enable the SSL and get rid of this error, then install the certificate in the trusted certificate store of your local computer.
    Tuesday, March 14, 2006 11:50 AM
  • I also have this problem. I have my virtual directories under the default website for Windows Server 2003 IIS 6.0. I have installed the certificates and the the report server works in SSL, but not the Report Manager and the default webpage (home.aspx-->page/folders.aspx) states the "could not establish trust relationship..." error. Please advise and thanks in advance.

    r,

    Clem

    Thursday, November 23, 2006 2:14 AM
  • I had the same problem, but I had entered the wrong certificate name in the Reporting services configuration manager -> Report server virtual directory -> Certificate name.

    I had used myName instead of myName.domain.com that was the correct name of the certificate to use.

    Thursday, February 15, 2007 10:49 AM
  • I had the same problem, and tried everything, not working.

     

    However, in the reports service configuration manager check the SSL --> Restart --> IISRESET--> uncheck SSL --> Restart --> IISRESET did the final trick. Now it is working without SSL whtich is what I wanted.

     

    Wednesday, August 13, 2008 8:01 PM
  • Tarek:

     

    I have the same problem. But when I navigate to Reporting Services Configuration Manager/Web Service URL, I don't see any checkbox to turn off Require SSL.

     

    Can you help?

     

    Venki

     

    Monday, August 18, 2008 9:36 PM
  • This solution was mentioned earlier. Just now i resolved it. Follow the below steps:

     

    1. Open Start -> Program Files -> Microsoft Sqlserver 2005-> Configuration Tools -> Reporting Services Configurations

    [Hope u already did this ]

    2.  Select "Reporting Server Virtual Directory" in the left panel. [here u will find the check box]

    3. Uncheck "Secure Socket Layer (SSL) Connections.

     
    Tuesday, August 26, 2008 5:48 AM
  • Hi,
    Please check the Server Date and Time. if both servers date and time difference is too long then you will receive this error.  If you really want SSL the above suggestion may not suit.

    Thanks,
    Suyaraj M
    • Proposed as answer by Suyaraj M Saturday, February 28, 2009 7:15 PM
    Saturday, February 28, 2009 7:11 PM
  • I really need SSL and this error still follow me. Some one have done it with SSL. I installed the certificate  and I can navegate in  https://myserver/ReportServer ... but https://mysite/Reports still with the same error:

    The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.

    Some one has done with SSL
    Friday, July 24, 2009 8:50 PM
  • Any solutions for this? I have the same problem. I want to stay in SSL, but running into the same issue. anyone has any ideas? Thanks
    Tuesday, September 1, 2009 7:22 PM
  • Hi hs2009,

    Please look at this article http://support.microsoft.com/kb/915599
    Wednesday, September 9, 2009 6:00 PM
  • Most probably your Reports and Report Server is not configured correctly on your IIS website (default or whatever). Also check if the related SQL services are running.
    I faced the same issue and came here for an answer. It worked for me this way =

    Eventually, i deleted the certificate then the reports and reportserver from IIS website (inetmgr)
    > reconfigured the certificate (use machine's fully qualified name i.e. machine.domain)
    > From reporting services configuration, reconfigure reportserver and reports.
    > In report server virtual directory settings -> check the checkbox for ssl, require for - 3 All SOAP APIs, machine's FQN.

    Finish rest of the configuration if any.

    Friday, September 25, 2009 1:26 PM
  • hi Murty k

    how about this error happen in Microsoft Sqlserver 2008,

    after steping through "Open Start ->All Programs -> Microsoft Sql Server 2008-> Configuration Tools -> Reporting Services Configuration Manager"

    I can't find checkbox to uncheck "Secure Socket Layer (SSL) Connections" in 2008

     

    what should I do?

    Monday, May 23, 2011 5:23 AM