locked
VS 2019 and EF core Core with ,net standard RRS feed

  • Question

  • User81789783 posted

    i m facing below error ,can any share me how to address this ??

    Severity    Code    Description    Project    File    Line    Suppression State
    Error    MSB3644    The reference assemblies for netcoreapp3.0,Version=v0.0 were not found. To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application. You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks    SamuraiApp.Data    C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Current\Bin\Microsoft.Common.CurrentVersion.targets    1180    

    Friday, November 27, 2020 11:43 AM

All replies

  • User475983607 posted

    Did you follow the instructions in the error message?  

    Friday, November 27, 2020 12:33 PM
  • User81789783 posted

    yes follow

    now facing below error

    Severity    Code    Description    Project    File    Line    Suppression State
    Error    NU1201    Project SamuraiApp.Domain is not compatible with netcoreapp30 (netcoreapp3.0,Version=v0.0). Project SamuraiApp.Domain supports: netstandard2.0 (.NETStandard,Version=v2.0)    SamuraiApp.Data    C:\Users\Aqib\source\repos\SamuraiApp\SamuraiApp.Data\SamuraiApp.Data.csproj    1    

    Friday, November 27, 2020 1:27 PM
  • User475983607 posted

    Another very clear error.  Your project support netstandard 2.0 not 3.0. 

    Read the migration guide and follow the recommendations if you are trying to upgrade a project to .NET 5.

    https://docs.microsoft.com/en-us/aspnet/core/migration/31-to-50?view=aspnetcore-5.0&tabs=visual-studio

    Friday, November 27, 2020 2:43 PM