locked
How to get rid double spacing in Sharepoint Page Content. RRS feed

  • Question

  • I am sick of Sharepoint Page Layout content. I am trying to create a bio page with image on left and text on right of it, but i couldnt find best page layout.

    I created an Article Page with Image on left page, but now everytime i hit enter i get double spacing between lines. I know how to change it using html but i dont want to do this over and over for every article i write.

    Is there a way i can  straighten this out.Instead of double spcing i want single spacing.

     


    Napster123

    • Edited by Mike Walsh FIN Wednesday, August 3, 2011 4:18 PM Second question removed. Post ONE question per thread.
    Wednesday, August 3, 2011 3:26 PM

Answers

All replies

  • Napster,

    The SharePoint content editor gives you a double space every time you press enter, if you just want a single space press Shift+Enter.
     
    You can also extend the style definitions so that the editor applies single-line spacing instead of double-line spacing when an editor hits Enter key. Refer link for similar example:
    http://mikeknowles.com/blog/2009/01/31/HowToCustomizeSharePointPublishingContentEditingStyles.aspx


    Leonid Lyublinski Wizard of MOSS
    • Proposed as answer by Jayant Sharma Thursday, August 4, 2011 5:03 AM
    • Marked as answer by Emir Liu Friday, August 12, 2011 10:18 AM
    Wednesday, August 3, 2011 7:56 PM
  • Thank You very much Leonid,

                  Do you have any links about sharepoint content editing . I would appreciate that a lot.

     

    Thank You


    Napster123
    Thursday, August 4, 2011 3:45 PM
  • I am not sure if this will apply to you, but this is what I was able to do to fix the problem...

    Remove unwanted double-spacing in Sharepoint documents.

    - Problem: Sometimes Sharepoint will force double-spacing between lines of text as you enter them into the text editor.

    - Detail: Online research revealed that this is a known Microsoft bug. I experimented, and found that this problem usually starts happening if you manually double-space by pressing Enter twice in a row, without entering any text in-between. All subsequent presses of the Enter key become double-spaced.

    - Solution: 1. Change default Sharepoint rich-text editor to Rad Editor. As part of the fix, I changed this Sharepoint's site default rich text editor to the Rad editor by turning on the Rad editor options under Site Actions --> Site Settings --> Site Features. Using the Rad editor istead of the regular editor should also prevent us from seeing this problem again. I tested, and was not able to duplicate the problem after switching the site over to this editor. 2. Using the Rad editor (see "Note", above), I was able to fix this problem in documents that I was editing by selecting the Format Stripper icon (the icon looks like a paint brush on a piece of paper), and selecting both the "Cascading Style Sheets" and "Microsoft Word Formatting" options from its drop-down menu.

    I am not sure yet which one of those fixed the double-spacing problem, but I know that it was one of the 2. Add to this discussion if you figure out which of the two options fixes the issue.


    Tuesday, December 13, 2011 10:46 PM
  • Very helpful! I just assumed that you had to live with double spacing in Sharepoint.
    Tuesday, August 21, 2012 8:17 PM
  • I realize this is an old post, but I am currently having a need to have a single spacing (inserted <br> rather than <p> ?) default rather than an "apparent" double spacing.

    The link in this answer is no longer valid.

    any help would be greatly appreciated!

    Tuesday, March 1, 2016 8:16 PM