locked
why my tfs proxy not work? RRS feed

  • Question

  • I installed TFS PROXY,but can not see any cache files in root folder.

    i am in location A, TFS is in location B.
    Proxy server also is location A,join B domain.A and B is the same LAN.

    At proxy server access http://localhost:8081/VersionControlProxy/v1.0/proxystatistics.asmx is ok ,Click QueryProxyStatistics and invoke button is still no error,in invoke XML files ,can see

    <CurrentCacheSize>0</CurrentCacheSize>
      <TotalDownloadRequests>0</TotalDownloadRequests>
      <TotalCacheHits>0</TotalCacheHits>
      <TotalFilesInCache>0</TotalFilesInCache>



    proxy.config has been changed to
    <Server>
     <Uri>http://TFSIP:8080</Uri>
     </Server>
     
    TFS Proxy account is tfssetup.
    i do not know why proxy can not work.
    snoopy
    • Moved by YiChun Chen Wednesday, June 17, 2009 9:13 AM TFS issue (From:Visual Studio Setup and Installation)
    Tuesday, June 16, 2009 10:34 AM

Answers

  • Proxy server stores the files which are downloaded from TFS in the root folder. Most probably you have not given 'Write' permission to TfsSetup user to the folder where proxy server stores the files. Please check that permission.
    VP, Technology, SEED Infotech Ltd.
    • Marked as answer by Hua Chen Thursday, June 25, 2009 9:10 AM
    Wednesday, June 17, 2009 3:53 PM
  • Hi,

    In order to use the TFS proxy, you also need to add it in Visual Studio on the client: Tools ->Options ->Source Control -> Visual Studio Team Foundation Server : Use Proxy server.

    Once you set it, try to Get Latest (force get) - that should fil-up the proxy cache. If not, can you check if you get any errors?

    Alin,
    TFS Hosting and Consulting Services.
    • Proposed as answer by Matthew Mitrik Wednesday, June 24, 2009 2:35 PM
    • Marked as answer by Hua Chen Thursday, June 25, 2009 9:10 AM
    Wednesday, June 17, 2009 9:03 PM

All replies

  • Hi Cyzsnoopy,

    I am moving this thread from Base "Visual Studio Setup and Installation" forum to the "Team Foundation Server - General" forum, since the issue is related to TFS. There are more experts in the "Team Foundation Server - General" forum.

    Thanks
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Wednesday, June 17, 2009 9:12 AM
  • Proxy server stores the files which are downloaded from TFS in the root folder. Most probably you have not given 'Write' permission to TfsSetup user to the folder where proxy server stores the files. Please check that permission.
    VP, Technology, SEED Infotech Ltd.
    • Marked as answer by Hua Chen Thursday, June 25, 2009 9:10 AM
    Wednesday, June 17, 2009 3:53 PM
  • Hi,

    In order to use the TFS proxy, you also need to add it in Visual Studio on the client: Tools ->Options ->Source Control -> Visual Studio Team Foundation Server : Use Proxy server.

    Once you set it, try to Get Latest (force get) - that should fil-up the proxy cache. If not, can you check if you get any errors?

    Alin,
    TFS Hosting and Consulting Services.
    • Proposed as answer by Matthew Mitrik Wednesday, June 24, 2009 2:35 PM
    • Marked as answer by Hua Chen Thursday, June 25, 2009 9:10 AM
    Wednesday, June 17, 2009 9:03 PM
  • Are you sure about this? I would have thought that the proxy server settings in Visual Studio were for setting up a connection through a non-TFS proxy like ISA Server?

    I've tried connecting directly to my TFS Proxy which doesn't work. I've also tried what you suggested (add the proxy into Tools > Options > SC) then connect to the TFS app box, however this doesn't seem to use the proxy as even when I force-get-latest there are no files in the data cache folder on the TFS Proxy.

    Thanks in advance.
    Luke
    Tuesday, December 15, 2009 4:25 AM