none
What past VS version can use Windows 7 and doesn't require Windows 8 or 10 for anything?

    Question

  • I have been trying to deploy an app that I wrote in C# and it comes back with this error message:

    Severity Code Description Project File Line Suppression State
    Error Error : DEP3320 : Target device's operating system version does not meet the application's minimum requirement. Minimum required operating system is Windows 10.0. MiniCalc

    What past VS version can use Windows 7 and doesn't require Windows 8 or 10 for anything?  Any help would be appreciated.  Thanks.


    Saturday, January 9, 2016 12:04 AM

Answers

  • Hi Surfview,

    Could you tell me what’s your project type and which version of VS did you use?

    >> DEP3320 : Target device's operating system version does not meet the application's minimum requirement. Minimum required operating system is Windows 10.0.

    From the error message. I guess you were deploying “UWP” application. If in this case, you have to deploy it on windows 10.

    >>What past VS version can use Windows 7 and doesn't require Windows 8 or 10 for anything?

    If you were deploying the windows application.  And your OS is windows 7.

    As far as I know. VS Express for windows. This version of VS is not support to deploy the windows application.

    So I suggest you may need to use VS2015 community or VS2015 express for windows desktop to deploy your application.

    Please take a look at the following document about Visual Studio 2015 Compatibility:

    https://www.visualstudio.com/en-us/products/visual-studio-2015-compatibility-vs.aspx

    Best Regards,

    Lake Xiao

    Monday, January 11, 2016 5:32 AM
    Moderator