locked
Disabling parallel builds on solution level RRS feed

  • Question

  • Hi,

    I have projects with custom build targets and I need to ensure that these project will not be built in parallel regardless of MSVC build and run settings. How do I achieve that? I assume it should be possible to disable this in solution file, but I wasn't able to find any documentation. Any hints are very appreciated.

    Saturday, July 9, 2016 2:16 AM

Answers

  • Hi Matej_K,

    For your case, I suggest you set Tools -> Options->Projects and Solutions\VC++ Project Settings->Maximum concurrent C++ compilations to 0 and Project properties->Configuration Properties > C/C++ > General->Multi-Processor Compilation to NO.

    Best Regards,
    Li Wang

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Albert_Zhang Monday, August 1, 2016 1:58 AM
    Tuesday, July 26, 2016 9:46 AM

All replies

  • Hi Matej_k,

    >>“I have projects with custom build targets and I need to ensure that these project will not be built in parallel regardless of MSVC build and run settings.”

    I'm not so clear your requirement, could you description more detail about this?
    According to your description, I guess:

    1. You have a solution included a lot of projects, solution has the reference(Multiple to Primary), you want to only build the main project.

    specify project file of a solution using msbuild

    2. Your commandline have multiple targets, you want to choose one target to build.

    How to: Build Specific Targets in Solutions By Using MSBuild.exe

    Best Regards,
    Li Wang


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, July 11, 2016 7:49 AM
  • Sorry, I wasn't more specific. I need to disable parallel builds when building from MSVC IDE. I know there is option for this in Build and Run settings, but that is per user. I'd need per solution settings so that other users building the solution would also have parallel builds disabled.
    Monday, July 11, 2016 10:00 AM
  • Hi Matej_K,

    For your case, I suggest you set Tools -> Options->Projects and Solutions\VC++ Project Settings->Maximum concurrent C++ compilations to 0 and Project properties->Configuration Properties > C/C++ > General->Multi-Processor Compilation to NO.

    Best Regards,
    Li Wang

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Albert_Zhang Monday, August 1, 2016 1:58 AM
    Tuesday, July 26, 2016 9:46 AM
  • I am concerned that a per-solution setting is not available even though the accepted answer from "DotNet Wang" (Li Wang) suggests it is. Even as all projects in a solution have uniform (via Property Sheets) setting of:

    Project properties->Configuration Properties > C/C++ > General->Multi-Processor Compilation -> No

    Projects themselves are still being build in parallel, even the per-user setting of:

    Tools -> Options->Projects and Solutions\VC++ Project Settings->Maximum concurrent C++ compilations -> 0

    documents, that "A  value of 0 causes all available processors to be utilized". With that setting projects themselves are still build in parallel. That is true even if that setting is set to 1.

    To turn off parallel building of projects instead of the above it seems to be necessary to set:

    Tools -> Options->Projects and Solutions -> Build and Run -> maximum number of parallel project builds -> 1

    That is, as the original poster knows, a user-level setting and does not seem to be retained in a solution.





    • Proposed as answer by Vlad Didenko Thursday, October 26, 2017 9:38 PM
    • Edited by Vlad Didenko Thursday, October 26, 2017 9:52 PM
    Thursday, October 26, 2017 9:35 PM
  • I ran into this problem as well. I agree this should be something configured per-solution.
    Tuesday, October 31, 2017 6:35 PM