locked
error while website running on server RRS feed

  • Question

  • User-1297444823 posted

    hi
    i created a website and its working  all well on my Computer But when i upload thi site on server it give Below Error ..

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.

    Source Error:

    Line 11:   <system.web>
    Line 12:     <customErrors mode="Off"/>
    Line 13: <compilation debug="true" targetFramework="4.0"> Line 14:       <assemblies>
    Line 15:         <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    Tuesday, March 5, 2013 1:11 PM

Answers

  • User71929859 posted

    Hello,

    how can i go to  IIS -> Application Pool and change the settings to .NET 4.0. ...?

    1. Open IIS.

    2. Click Application Pools.

    3. Double click on your website.

    4. Set the .Net framework version as '.Net Framework v4.0'.

    5. Click 'OK' and restart your application.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, March 10, 2013 2:37 PM

All replies

  • User-851967432 posted

    Does the server suppoert 4.0 framework?

    Tuesday, March 5, 2013 2:17 PM
  • User1196771204 posted

    Hi Nastik,

    The issue happens because the application pool, where your site is hosted, is not using ASP.NET 4.0 framework. Please go to your IIS -> Application Pool and change the settings to .NET 4.0. If you do not see this option there, this means that ASP.NET 4.0 has not been installed on the server.

    Please kindly mark this response as an "answer" if it helps you. Thanks heaps! 

    Tuesday, March 5, 2013 10:14 PM
  • User-1297444823 posted

    maybe not ..!
    i'm not sure but probably 4.0 framework no installed on server, can i solve this problem on my side (on My computer) .. ?

    Wednesday, March 6, 2013 12:51 AM
  • User-1297444823 posted

    how can i go to  IIS -> Application Pool and change the settings to .NET 4.0. ...?

    please help 

    Wednesday, March 6, 2013 12:55 AM
  • User1027872733 posted

    start->run->inetmgr>dbl click left pane->double click applicatio pool->click any where app pool (set version from drop down list)

    Wednesday, March 6, 2013 1:12 AM
  • User525278445 posted

    Please make sure framework 4.0 is working on your server. if framework 4.0 is available check with IIS in the application pool and change the setting to 4.0.

    Wednesday, March 6, 2013 11:42 PM
  • User71929859 posted

    Hello,

    how can i go to  IIS -> Application Pool and change the settings to .NET 4.0. ...?

    1. Open IIS.

    2. Click Application Pools.

    3. Double click on your website.

    4. Set the .Net framework version as '.Net Framework v4.0'.

    5. Click 'OK' and restart your application.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, March 10, 2013 2:37 PM