locked
Enable-SPFeature : The Feature is not a Farm Level Feature and is not found in a Site level defined by the Url RRS feed

  • Question

  • I'm trying to activate a web level feature using powershell with the following command:

    Enable-SPFeature –identity 3ad4787b-e859-432c-be22-c772725e0dbc -URL http://win-p8f03cpnjn5:5555/gateway/home/stafftravel/

    I get the following error 

    The Feature is not a Farm Level Feature and is not found in a Site level defined by the Url

    However I can see the feature in  site settings/site feature page.

    This commands works well for site collection features but fails on web scope activation.

    Any idea what am I missing?
    Monday, April 29, 2013 2:03 PM

Answers

All replies

  • Have you added the solution containing the feature with Add-SPSolution to the farm?

    C:\PS>Add-SPSolution -LiteralPath c:\contoso_solution.wsp

    Regards.
    Philip

    Monday, April 29, 2013 2:15 PM
  • Please check below thread

    http://iwillsharemypoint.blogspot.in/2012/05/enable-spfeature-feature-is-not-farm.html


    MCTS,MCPD Sharepoint 2010. My Blog- http://www.sharepoint-journey.com
    If a post answers your question, please click "Mark As Answer" on that post and "Vote as Helpful


    Monday, April 29, 2013 11:59 PM
  • Yes, Philip, I added the solution using ASS-SPSolution,
    Friday, May 3, 2013 1:47 PM
  • This did not work for me  :(  Still same error



    • Edited by CrjangelFG Thursday, January 2, 2014 6:21 PM no name
    Thursday, January 2, 2014 6:21 PM
  • Please check my article on this topic and see if it helps.

    http://moonistahir.wordpress.com/2014/01/06/enable-spfeature-issue-the-feature-is-not-a-farm-level-feature/


    Moonis Tahir MVP SharePoint,MCTS SharePoint 2010/2007, MCPD.net, MCSD.net, MCTS BizTalk 2006,SQL 2005

    Monday, January 6, 2014 8:18 PM
  • This is not the solution-  didn't work for me
    Monday, February 24, 2014 6:45 PM
  • Thank you for the suggestion - also did not work
    Monday, February 24, 2014 6:46 PM
  • This isnt always the answer. The reason is that the Feature may be installed under a different name in the FEATURES folder on the SharePoint Server.

    Go to 'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\FEATURES' on your SharePoint Server and check that the FolderName of the Feature you are trying to activate is the same as in your Powershell Command.

    e.g.

    Enable-SPFeature identity FeatureName.v1.0 -URL http://xxxxx

    But the FOLDERNAME in the FEATURES directory is 'FeatureName'

    Change the command to

    Enable-SPFeature identity FeatureName -URL http://xxxxx
    • Proposed as answer by MonaliB Thursday, May 10, 2018 7:13 AM
    Friday, April 25, 2014 2:00 PM
  • Deleted
    Thursday, May 8, 2014 12:10 PM