none
Access 2010 Pivot table from query not working RRS feed

  • Question

  • Good morning all-

    Curious if anyone has come across this issue:  I'm working in Access 2010 in Windows 7.  I have a query (qryB) which itself is based on another query (qryA).  When I try to open qryB as a pivot table, Access crashes, and gives me the options of Restart or Debug.

    However, if I make qryB as maketable query, and create a table, then open that table as a pivot, it works.

    Any ideas why this is happening?

    Monday, August 3, 2015 2:52 PM

Answers

All replies

  • Try to create a repro. Start with an empty database and import only those objects who are absolutely necessary (tables, views). Then try it again.

    btw, do you run compress and repair on close?

    Monday, August 3, 2015 3:05 PM
  • Hi Stefan-

    Though I do not run compress/repair on close, I do it manually regularly.  I have attempted to do that and immediately tried to do this pivot table view, and it still crashes.

    Also, I have found it's specific to one query.

    What I mean is this:

    qryB is based off of qryA
    qryY is based off of qryX

    trying to get a pivot table from qryB crashes.  qryY, however, will generate a pivot table view. (I only just found this out).

    I created a blank DB, and imported all four queries referenced above, and the same thing happens.  the Y/X combo will allow a pivot view, but the B/A combo crashes.

    Also, for what it's worth, qryA and qryX are both querying the same table.  So there isn't any issue with the underlying table.


    Also, I have tried to create a pivot table using qryA and it works.  So, there's some sort of issue with my qryB, but I cannot for the life of me figure it out....
    • Edited by Casey_M Monday, August 3, 2015 3:41 PM
    Monday, August 3, 2015 3:24 PM
  • Recreated the query itself, and the pivot table works.  There must've been something corrupt in that particular query.
    Monday, August 3, 2015 4:09 PM