none
How to open Design View in Visual Studio Express 2015 ?

    Question

  • Howdy,

    (This is likely to be the easiest one of the day...)

    If I open an HTML page using Visual Studio Express 2015, it brings me to a Code View.

    From that view, how do I launch the WYSIWYG Design View?

    (I've read that I should click on the "Design Tab" in the lower left, but no such tab is visible...)

    Sincere thanks,

    Lothar

    Wednesday, January 13, 2016 7:10 PM

Answers

  • Hi Lothar,

    Could you please tell me what’s the version of  your VS Express? For web or for desktop or for windows?

    As far as I know, only VS2015 Express for Web support to open with HTML(Web Forms).

    I did a test in my side using VS2015 Express for Web, and I can see the “HTML(Web Forms)” option successfully.

    So install the correct  version of VS and try it again.

    Best Regards,

    Lake Xiao

    Friday, January 15, 2016 10:08 AM
    Moderator

All replies

  • Try closing, then re-opening the file. If the HTML file is in Solution Explorer, then right-click and select “Open With”. Otherwise, open it with Open File dialog from File menu, but click the small dropdown arrow inside the Open button, then click “Open With”. Then select “HTML (Web Forms) Editor with Encoding”. Then you should see the Design, Split and Source buttons. Click Design.


    • Edited by Viorel_MVP Wednesday, January 13, 2016 7:56 PM
    Wednesday, January 13, 2016 7:55 PM
  • Hello,

    I sincerely appreciate your suggestions, but remain baffled...

    I start in Explorer, and navigate to the HTML file I wish to edit using WYSIWYG. I right click on the file and choose Open With. One of the options is Microsoft Visual Studio Version Selector. When I choose that option, the code for the HTML page displays in Microsoft Visual Studio Express 2015.

    Next, I click the "X" on the tab at the top to close the file...

    Then, looking at a blank VS  screen, I choose File | Open from the menu. A VS Open File dialog opens and I click on the dropdown arrow choosing open with.

    Six options appear:

    Automatic Editor Selector (XML) (Default) which brings me right to where I started, that is, to the VS HTML Text Editor.

    Beneath that choice, I see -

    XML (Text) Editor

    XML (Text) Editor with Encoding

    Source Code (Text) Editor

    Source Code (Text) Editor with Encoding

    Microsoft Edge

    There is no option for HTML (Web Forms) editor with or without encoding.

    How should I proceed to get that option to appear?

    All the best,

    Lothar

    Thursday, January 14, 2016 3:55 PM
  • Hello again,

    I thought it possible that I had somehow neglected to completely install VSE2015, perhaps accidentally excluding the HTML (Web Forms) Editor functionality.

    So, I ran a Repair of the VSE installation. The repair ran through, but at no point did it give me any installation options.

    After running the repair, there is still no Open With option for HTML (Web Forms) Editor...

    Thanks for any further thoughts,

    Lothar

    Thursday, January 14, 2016 5:13 PM
  • Hi Lothar,

    Could you please tell me what’s the version of  your VS Express? For web or for desktop or for windows?

    As far as I know, only VS2015 Express for Web support to open with HTML(Web Forms).

    I did a test in my side using VS2015 Express for Web, and I can see the “HTML(Web Forms)” option successfully.

    So install the correct  version of VS and try it again.

    Best Regards,

    Lake Xiao

    Friday, January 15, 2016 10:08 AM
    Moderator
  • Hi Lake,

    Indeed, I have the Desktop Version...!

    Thanks so much for spotting it,

    Lothar

    Friday, January 15, 2016 1:25 PM
  • Thanks for this post. Finally after several days of looking at other posts yours was the answer to my problem.
    Thursday, July 21, 2016 1:02 PM