none
.NET Framework 4 installs, but verification fails and .NET4 Applications will not run. RRS feed

  • Question

  • Running: Windows 7 x64 Ultimate

    I installed the .NET Framework 4 Client Profile and even tried installing the FULL/Extended edition the install appears to go in just fine, no errors or anything. Once I try to run a program it fails to work, I tried to verify my .NET4 installation using this tool...

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    It ALWAYS fails the verification no matter how many times I uninstall/clean up and reinstall...

    Here is a snippet from the verifier log...

    .....[07/22/10,17:35:35] Section [Registry - .NET Framework 4 Full (Wow6432Node)] - stop parsing entries
    [07/22/10,17:35:35] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [07/22/10,17:35:35] ExecutablePath = 'Netfx40TestApplication.exe'
    [07/22/10,17:35:35] FriendlyName = '.NET Framework 4 test application'
    [07/22/10,17:35:35] TimeoutSeconds = '300'
    [07/22/10,17:35:35] WaitOnExit = 'true'
    [07/22/10,17:35:35] Silent = 'true'
    [07/22/10,17:35:35] Launching process 'Netfx40TestApplication.exe' now
    [07/22/10,17:35:35] Process successfully launched. Waiting 300 seconds for it to complete.
    [07/22/10,17:35:35] ****ERROR**** Process 'Netfx40TestApplication.exe' exited with return code -2146232576
    [07/22/10,17:35:35] ****ERROR**** Verification failed for product .NET Framework 4 Full

    Full Log here: www.polaris-central.com/setupverifier_main_07-22-10_17.35.11.txt

     

    Anyone have any ideas whats wrong?

    Saturday, July 24, 2010 12:34 AM

Answers

  • Hi Forsaken6,

    Thank you for your post in MSDN forum!

     

    [07/22/10,17:35:35] Processing custom action 'Custom Action - .NET Framework 4.0 test application'

    [07/22/10,17:35:35] ExecutablePath = 'Netfx40TestApplication.exe'

    [07/22/10,17:35:35] FriendlyName = '.NET Framework 4 test application'

    [07/22/10,17:35:35] TimeoutSeconds = '300'

    [07/22/10,17:35:35] WaitOnExit = 'true'

    [07/22/10,17:35:35] Silent = 'true'

    [07/22/10,17:35:35] Launching process 'Netfx40TestApplication.exe' now

    [07/22/10,17:35:35] Process successfully launched. Waiting 300 seconds for it to complete.

    [07/22/10,17:35:35] ****ERROR**** Process 'Netfx40TestApplication.exe' exited with return code -2146232576

    [07/22/10,17:35:35] ****ERROR**** Verification failed for product .NET Framework 4 Full

     

    This issue could be caused by .NET Framework 4.

    I would provide you some steps, which you could try to do it one by one.

    1, could you please uninstall .NET Framework 4 on your machine?

    2, could you download .NET Framework 4 from the following link?

     

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7

    3, unable your anti-virus software and some security software

    4. Run your setup file as administrator

    5, install Microsoft .NET Framework 4 again

    If the installation is failed, you could follow the following steps one by one.

    1, you could download ‘Collect.exe’, which could help you to collect information during installing products. The following link is: http://go.microsoft.com/?LinkId=8967043

    How to use this tool, you could click the link as follows?

    http://blogs.msdn.com/b/astebner/archive/2007/08/01/4172276.aspx

    2, Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")

    4. Run your setup file as administrator

    5, re-install Microsoft .NET Framework 4 again

     

    It will create a file named %temp%\vslogs.cab on your system.

    If it does not work, you could refer your log files to narrow down your issue.

    Or you could send your log files to me. (My E-Mail: v-xugong@microsoft.com)

    Note: Please attach the link of this post in the mail.

    At last, you could use the verification tool to verify whether your framework is installed or not.

    Look forward to your good news!

     

    Hope this helps you! If you have any doubts and concerns, please feel free to let me know. We are going to continue to follow-up.

    Best Regards

    Larcolais Gong

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, July 26, 2010 7:35 AM
  • Thank you for trying to help, I managed to solve the issue by formatting my system drive and reinstalling windows, that fixed it, If I had seen these posts sooner I would have tried these first! haha.

     

    Thank you again.

    • Marked as answer by Larcolais Gong Wednesday, September 1, 2010 1:29 AM
    Friday, July 30, 2010 1:55 AM

All replies

  • Hi Forsaken6,

    Thank you for your post in MSDN forum!

     

    [07/22/10,17:35:35] Processing custom action 'Custom Action - .NET Framework 4.0 test application'

    [07/22/10,17:35:35] ExecutablePath = 'Netfx40TestApplication.exe'

    [07/22/10,17:35:35] FriendlyName = '.NET Framework 4 test application'

    [07/22/10,17:35:35] TimeoutSeconds = '300'

    [07/22/10,17:35:35] WaitOnExit = 'true'

    [07/22/10,17:35:35] Silent = 'true'

    [07/22/10,17:35:35] Launching process 'Netfx40TestApplication.exe' now

    [07/22/10,17:35:35] Process successfully launched. Waiting 300 seconds for it to complete.

    [07/22/10,17:35:35] ****ERROR**** Process 'Netfx40TestApplication.exe' exited with return code -2146232576

    [07/22/10,17:35:35] ****ERROR**** Verification failed for product .NET Framework 4 Full

     

    This issue could be caused by .NET Framework 4.

    I would provide you some steps, which you could try to do it one by one.

    1, could you please uninstall .NET Framework 4 on your machine?

    2, could you download .NET Framework 4 from the following link?

     

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7

    3, unable your anti-virus software and some security software

    4. Run your setup file as administrator

    5, install Microsoft .NET Framework 4 again

    If the installation is failed, you could follow the following steps one by one.

    1, you could download ‘Collect.exe’, which could help you to collect information during installing products. The following link is: http://go.microsoft.com/?LinkId=8967043

    How to use this tool, you could click the link as follows?

    http://blogs.msdn.com/b/astebner/archive/2007/08/01/4172276.aspx

    2, Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")

    4. Run your setup file as administrator

    5, re-install Microsoft .NET Framework 4 again

     

    It will create a file named %temp%\vslogs.cab on your system.

    If it does not work, you could refer your log files to narrow down your issue.

    Or you could send your log files to me. (My E-Mail: v-xugong@microsoft.com)

    Note: Please attach the link of this post in the mail.

    At last, you could use the verification tool to verify whether your framework is installed or not.

    Look forward to your good news!

     

    Hope this helps you! If you have any doubts and concerns, please feel free to let me know. We are going to continue to follow-up.

    Best Regards

    Larcolais Gong

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, July 26, 2010 7:35 AM
  • Hi Matt,

    I'm writing to follow-up this post. Do the above suggestions help you solve your concerns?

    I'm marking this post as Answered. If you have any findings and concerns, please feel free to unmark this post.

    Kind Regards

    Larcolais Gong

    Please remember to mark the replies as answers if they help and unmark them if they provide no help

    Friday, July 30, 2010 1:43 AM
  • Thank you for trying to help, I managed to solve the issue by formatting my system drive and reinstalling windows, that fixed it, If I had seen these posts sooner I would have tried these first! haha.

     

    Thank you again.

    • Marked as answer by Larcolais Gong Wednesday, September 1, 2010 1:29 AM
    Friday, July 30, 2010 1:55 AM