none
ISA15 - Test or Production RRS feed

  • Question

  • I'm using Biztalk R2.  When I go to the "EDI Properties" of a "Party" and set the "ISA Segment Definitions" in the "Party as an Interchange Receiver", the properties are not translating into my edi document.  For instance, I have set the ISA15 (Usage Indicator) to a "T", but after the document goes through translation, it still has  "P" in the final edi output.

     

    Can someone tell me why my current ISA values are not translating into my final output?

    Tuesday, August 14, 2007 7:39 PM

Answers

  • This could be due to the settings being applied from the global properties as opposed to party properties if party resolution did not find a party. Try associating the send port with the party you are trying to apply the settings from, restart the biztalk service and retry your scenario. That should work.

     

    P.S: Any time you make a change in the party setting, there is a 15 minute caching latency. To apply the settings immediately, simply restart biztalk service.

     

    Thanks

    Mohsin

    Tuesday, August 14, 2007 9:11 PM

All replies

  • This could be due to the settings being applied from the global properties as opposed to party properties if party resolution did not find a party. Try associating the send port with the party you are trying to apply the settings from, restart the biztalk service and retry your scenario. That should work.

     

    P.S: Any time you make a change in the party setting, there is a 15 minute caching latency. To apply the settings immediately, simply restart biztalk service.

     

    Thanks

    Mohsin

    Tuesday, August 14, 2007 9:11 PM
  • Thanks, but no luck.

     

    Even in the Global Properties, I have the ISA15 value set to a "T" but I still get a "P" in my edi output.  Is it still necessary to have the Party "Alias" even with the new EDI Properties of R2?  When I remove the alias from my Party I get a "recipient of the document is not recognized".  I can't seem to get it to recognize my new EDI Properties at all.

     

    The ISA segment of my document looks like this:

    ISA*00*          *00*          *ZZ*MYCOMPANY    *01*123456789      *070820*1250*U*00401*000010304*0*P*>

     

    In my Parties EDI Properties, I have the "Party as Interchange Receiver" as such:

    ISA5:ZZ

    ISA6:MYCOMPANY

    ISA7:01

    ISA8:123456789

     

    What am I missing?

    Monday, August 20, 2007 5:13 PM
  • Try associating the Party you are trying to apply the settings from with the SendPort you are using and see if that helps.

     

    I am working on a post about Party Resolution for the EDI blog that might help you in understanding this issue. I will let you know once that is done.

     

    Thanks

    Mohsin

    Thursday, August 23, 2007 2:13 AM