none
dotner core: Too many levels of symbolic links RRS feed

  • Question

  • dotner core: Too many levels of symbolic links

    I'm trying build the code of dotnet core on linux, but I've been receive the next error:

    [limup@localhost salao]$ dotnet build
        Microsoft (R) Build Engine version 16.4.0+e901037fe for .NET Core
        Copyright (C) Microsoft Corporation. All rights reserved.
        
          Restore completed in 67.43 ms for /home/limup/Documents/Projetos/Limup/salao/salao.csproj.
        /usr/share/dotnet/sdk/3.1.101/Sdks/Microsoft.NET.Sdk.Razor/build/netstandard2.0/Microsoft.NET.Sdk.Razor.CodeGeneration.targets(99,5): error MSB6003: The specified task executable "dotnet" could not be run. System.ComponentModel.Win32Exception (40): Too many levels of symbolic links [/home/limup/Documents/Projetos/Limup/salao/salao.csproj]
        /usr/share/dotnet/sdk/3.1.101/Sdks/Microsoft.NET.Sdk.Razor/build/netstandard2.0/Microsoft.NET.Sdk.Razor.CodeGeneration.targets(99,5): error MSB6003:    at System.Diagnostics.Process.ForkAndExecProcess(String filename, String[] argv, String[] envp, String cwd, Boolean redirectStdin, Boolean redirectStdout, Boolean redirectStderr, Boolean setCredentials, UInt32 userId, UInt32 groupId, UInt32[] groups, Int32& stdinFd, Int32& stdoutFd, Int32& stderrFd, Boolean usesTerminal, Boolean throwOnNoExec) [/home/limup/Documents/Projetos/Limup/salao/salao.csproj]
        /usr/share/dotnet/sdk/3.1.101/Sdks/Microsoft.NET.Sdk.Razor/build/netstandard2.0/Microsoft.NET.Sdk.Razor.CodeGeneration.targets(99,5): error MSB6003:    at System.Diagnostics.Process.StartCore(ProcessStartInfo startInfo) [/home/limup/Documents/Projetos/Limup/salao/salao.csproj]
        /usr/share/dotnet/sdk/3.1.101/Sdks/Microsoft.NET.Sdk.Razor/build/netstandard2.0/Microsoft.NET.Sdk.Razor.CodeGeneration.targets(99,5): error MSB6003:    at System.Diagnostics.Process.Start() [/home/limup/Documents/Projetos/Limup/salao/salao.csproj]
        /usr/share/dotnet/sdk/3.1.101/Sdks/Microsoft.NET.Sdk.Razor/build/netstandard2.0/Microsoft.NET.Sdk.Razor.CodeGeneration.targets(99,5): error MSB6003:    at Microsoft.Build.Utilities.ToolTask.ExecuteTool(String pathToTool, String responseFileCommands, String commandLineCommands) [/home/limup/Documents/Projetos/Limup/salao/salao.csproj]
        /usr/share/dotnet/sdk/3.1.101/Sdks/Microsoft.NET.Sdk.Razor/build/netstandard2.0/Microsoft.NET.Sdk.Razor.CodeGeneration.targets(99,5): error MSB6003:    at Microsoft.AspNetCore.Razor.Tasks.DotNetToolTask.ExecuteTool(String pathToTool, String responseFileCommands, String commandLineCommands) [/home/limup/Documents/Projetos/Limup/salao/salao.csproj]
        /usr/share/dotnet/sdk/3.1.101/Sdks/Microsoft.NET.Sdk.Razor/build/netstandard2.0/Microsoft.NET.Sdk.Razor.CodeGeneration.targets(99,5): error MSB6003:    at Microsoft.Build.Utilities.ToolTask.Execute() [/home/limup/Documents/Projetos/Limup/salao/salao.csproj]
    
    

    Does anyone know how to resolve this error?

    Environment Data

    [limup@localhost salao]$ dotnet --info
    .NET Core SDK (reflecting any global.json):
     Version:   3.1.101
     Commit:    b377529961
    
    Runtime Environment:
     OS Name:     fedora
     OS Version:  31
     OS Platform: Linux
     RID:         fedora.31-x64
     Base Path:   /usr/share/dotnet/sdk/3.1.101/
    
    Host (useful for support):
      Version: 3.1.1
      Commit:  a1388f194c
    
    .NET Core SDKs installed:
      3.1.101 [/usr/share/dotnet/sdk]
    
    .NET Core runtimes installed:
      Microsoft.AspNetCore.App 3.1.1 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
      Microsoft.NETCore.App 3.1.1 [/usr/share/dotnet/shared/Microsoft.NETCore.App]
    
    To install additional .NET Core runtimes or SDKs:
      https://aka.ms/dotnet-download

    OBS

    Tried Fixes put in dotnet restore, but I received the same error.

    Did not have this problem with dotnet sdk 2.0.


    Thursday, January 16, 2020 2:36 PM

Answers

All replies

  • Hi Arnaldo Vieira de Lima Junior,

    Thank you for posting here.

    According to your description, I find two references about install .NET Core 3.1 in Fedora 31.

    1. Fedora 31 Package Manager - Install .NET Core
    2. Cannot install .NET Core 3.1 using Fedora 31

    Hope them could be helpful.

    Best Regards,

    Xingyu Zhao


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, January 17, 2020 8:21 AM
    Moderator
  • Hi Arnaldo Vieira de Lima Junior,

    Thank you for posting here.

    According to your description, I find two references about install .NET Core 3.1 in Fedora 31.

    1. Fedora 31 Package Manager - Install .NET Core
    2. Cannot install .NET Core 3.1 using Fedora 31

    Hope them could be helpful.

    Best Regards,

    Xingyu Zhao


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Hi Xingyu Zhao,

    Thanks for response.

    Unfortunately, I remove Fedora 31 and install Debian 10. Honestly, I hadn't seen it.

    I didn't know that dotnet had repository for Fedora 31.

    Anyway, thank you for the help.

    Closed.

    Saturday, January 18, 2020 1:27 AM