EDI X12 850 Purchase Order to XML Map failing with error RRS feed

  • Question

  • Hi All,

    I VS2010 solution to tranform the 850 Purchase order to an XML file.

    I have the added the source schema as X12_00401_850.xsd and taget schema accordingly. I have deployed the solution. While i tried to test the solution i get the below error:

    Error encountered during parsing. The X12 transaction set with id '' contained in functional group with id '003866102', in interchange with id '003866102', with sender id '4165889000 ', receiver id '081466849 ' is being suspended with following errors:

    Error: 1 (Miscellaneous error)

    6: Finding the document specification by message type "http://schemas.microsoft.com/BizTalk/EDI/X12/2006#X12_00200_850" failed. Verify the schema deployed properly.


    Please find below my test file

    ISA~00~          ~00~          ~12~4165889000     ~01~081466849      ~111025~0833~U~00200~003866102~0~P~*GS~PO~SCC_MS850~MSLICENSE~20111025~0833~003866102~X~004010ST~850~003866102BEG~00~NE~3591002~~20111025CUR~EB~USDREF~PG~S6DTM~007~20111025N1~BT~Softchoice Corporation~91~0005005704REF~AH~6839961PO1~FD2861~1~EA~386.76~~MG~79P-03586REF~EU~78514980CDREF~ZZ~USCTT~1~1SE~12~003866102GE~000001~003866102IEA~00001~003866102

    Please kindly help. I am pretty new to BizTalk development. Your help is much appreciated.


    Monday, October 31, 2011 7:57 AM

All replies

  • Hi Shonai,

    Have you configured the party for this 850?

    Monday, October 31, 2011 8:35 AM
  • Yes i have created Parties and also an agreement with the necessary data.

    Monday, October 31, 2011 8:43 AM
  • Can you go the "all artifacts" in your BizTalk Administration Console and choose "Schemas"

    See if you have exactly one schema deployed with:

    - Target Namespace: http://schemas.microsoft.com/BizTalk/EDI/X12/2006

    - Root Name: X12_00200_850

    If not then make sure that there is such a schema deployed.

    Morten la Cour

    Monday, October 31, 2011 8:44 AM
  • Hi Morten,

    Thanks for you reply, I have one schema deployed with Target namespace as http://schemas.microsoft.com/BizTalk/EDI/X12/2006 and Root Name as X12_00401_850

    I am not sure why is Biztalk looking out for the Root name X12_00200_850. Also i cannot find any such schema in the  Biztalk Install folder C:\Program Files (x86)\Microsoft BizTalk Server 2010\XSD_Schema\EDI\MicrosoftEdiXSDTemplates\X12 




    • Edited by Shonai Monday, October 31, 2011 8:52 AM
    Monday, October 31, 2011 8:52 AM
  • The 00200 is the version number of the X12 standard used. BizTalk supports from 204 and above, so either have your Trading partners send a newer version, or deploy a 204 version, where you change the rootname of the schema to 00200 and also the type name. This is ofcourse not 100% acuate, but the changes from 200 to 204 is probably minimal.


    Morten la Cour

    Monday, October 31, 2011 9:14 AM
  • Thank you guys your discussion solved my queries on the similar lines :).

    Shailender Singh MCP DOTNET 3.5
    Friday, December 16, 2011 9:30 AM
  • Thank you guys your discussion solved my queries on the similar lines :).

    Shailender Singh MCP DOTNET 3.5

    Hi Shailender,

    I am also facing the same problem. Want to process the X12 message for 002003 version, In BizTalk schema is not there. When i am trying to update this, it is behaving incorrectly. Please help


    Sunday, June 11, 2017 7:45 PM