none
Error 10013 attempting to connect to SOAP web service from Windows 8 client app RRS feed

  • Question

  • I have used Visual studio 2003, 2008 and 2010 for years to make clients to SOAP web services using web
    references. I am now trying to make a Windows 8 client using VS2012. The
    service reference has no trouble connecting to the web service and it creates all
    the objects successfully. But when I run the
    app and try to connect to the web
    service, it throws an error "There was no endpoint listening at...",
    and the inner exception is "An attempt was made to access a socket in a
    way forbidden by its access permissions" with SocketErrorCode 10013
    (Access Denied). Now since the service reference created all the objects, it
    obviously was able to retrieve the WSDL from the service. What am I doing
    wrong? I'm also new to async functions, so maybe I'm doing that wrong?

    I run VS2012 As Adminsitrator, so I don't think the account permissions is a problem.

    Note also that I do not use WCF to create the web services; they are all standard SOAP services, which I connect to using a Web Reference.  

    Code:<o:p></o:p>

    ' Service reference is MyTestSvc
    Dim MySvcClient As New MyTestSvc.MyServiceSoapClient()
    Dim req As New MyTestSvc.UserReq
    Dim resp As New MyTestSvc.UserRequestResponse
    req.username = “Test”
    req.password = “Test”
    Try
     Dim respTask As Task(Of MyTestSvc.UserInfoRequestResponse) = MySvcClient.GetUserInfo(req)
     resp = Await respTask
     Return True
    Catch ex As Exception
     Return False
    End Try


    Davesemm

    • Moved by Cindy Meister MVP Wednesday, December 12, 2012 7:40 AM not VSTO or Office related (From:Visual Studio Tools for Office)
    Wednesday, December 12, 2012 6:58 AM

Answers

All replies