locked
July 1st - Apps I've been working on no longer load

    Question

  • On the 1st my developer license expired (OK, it expires every 30 days; no problem, I'll renew it; which I did).  However, even after getting a new developer license that is current the apps built using the old cert appears to not pick up the new license.

    I haven't found a way to correct it (or the correction isn't obvious).

    Thanks,

    Ken

    Wednesday, July 04, 2012 4:52 AM

All replies

  • May I know what kind of error you get whenever you try to load project built using expired license?

    Subramanian Muthukrishnan Microsoft Student Partner iLink Systems General Secretary,Rockcity Dot Net User Group Windows 8 Trainer,DPE Program for Windows 8,Microsoft.

    Wednesday, July 04, 2012 8:44 AM
  • The error reported that the Application could not be loaded and that the store may be able to correct the issue (which as the application wasn't in the store it could not).  The application was never loaded; I tried setting break points in the very start of the App class and it was never hit.

    Specifically:

    Unable to activate Windows Metro style application 'MyApp1...'.  The activation request failed with error 'The application cannot be started'.  Try reinstalling the application to fix the problem.

    See help for advice on troubleshooting the issue.

    Thursday, July 05, 2012 6:26 PM
  • Have you tried to uninstall the app, clean the solution, delete obj/bin folders and reboot? I usually do that when VS doesn't want to start or deploy an app.
    Thursday, July 05, 2012 6:59 PM
  • Yes, I tried all that; I even made sure the AppData folder for the app was deleted before re-installing it.
    Friday, July 06, 2012 5:24 AM
  • Same situation -- renewed my license this morning & apps that worked yesterday now fail with same error.

    I am able to create new apps that work fine.

    Were you able to make any progress?  If not, I'll start trying random changes to if anything helps...

    Friday, July 06, 2012 5:21 PM
  • FWIW, I pulled down my sources, resources, and solution file from our source control into a new folder & it built/ran fine.

    Friday, July 06, 2012 6:39 PM
  • If you have built an app package for the store and the store updated your Package Name and your license for Visual Studio has been renewed since your last package build for the store you may get this error... "The activation request failed with error 'the application cannot be started'"

    To fix it just build another app package for the store now that you are running under your new license update.  Uninstall the app from your start page and then deploy again.

     
    • Edited by RBL_3 Monday, August 06, 2012 3:17 PM spelling
    Monday, August 06, 2012 3:16 PM
  • Try to change the version number in package.appxmanifest, that solved the problem for me.
    • Proposed as answer by Carl Partridge Sunday, September 30, 2012 6:16 PM
    Friday, August 10, 2012 6:22 PM
  • Try to change the version number in package.appxmanifest, that solved the problem for me.
    This worked well for me, as did uninstalling the existing app via the Start Menu

    Carl Partridge

    Sunday, September 30, 2012 6:16 PM
  • JonasO,

    Thanks much for that hint. It fixed my problem. Sweet!

    Friday, October 26, 2012 2:55 PM
  • The other option which worked for me is to go to the start screen, find the tile for the app (which should be there even if you debugged, if it's not there, use the search feature to find it).  Right click on the tile and choose un-install.  When you go back to run your app from VS it should work (I say it should, I mean it did for me). 

    What I think it should and what it does most of the time are two different things.  :D

    Monday, October 29, 2012 4:42 PM
  • this worked for me also ...
    Thursday, November 08, 2012 12:43 AM