none
Incoming connections blocked RRS feed

  • Question

  • Our software runs a web server and a telnet server for remote management. My WES7 device can get an IP and connect to other servers, but I am unable to connect to it. Connecting to localhost on the device works properly.

    I do not have the Windows Firewall package installed, and I don't know what else could be blocking it. Our network is not configured to block anything, so I am certain it is a WES7 configuration issue.

    Wednesday, September 22, 2010 2:56 PM

All replies

  • Do you have remote access enabled?

    Do you have other Windows 7 systems on the network and can you see them?

    -Sean

     


    www.sjjmicro.com / www.seanliming.com, Book Author - XP Embedded Advanced, XPe Supplemental Toolkit, WEPOS / POS for .NET Step-by-Step
    Thursday, September 23, 2010 12:24 AM
    Moderator
  • This morning I tried adding all networking packages except for the firewall and still had the issue. I installed the firewall and added an exception for our software and it worked perfectly. I still have to test what happens when it is switched to a new network, but the advanced firewall settings make it look like it works.

    I'm not sure why things get blocked without the firewall installed, but it's a good thing for our device to run anyways.

    Thursday, September 23, 2010 2:36 PM
  • I am having the exact same issue, without the firewall component I cannot ping the target image.  Here is what is really annoying.  If you do not install the firewall component, it disables all of the firewall options in netsh, but still blocks incoming packets.  If you look in the running services, Windows Firewall is present.  So by not adding the component, it only seems to remove the ability to control the firewall and it still installs it and runs it.  So annoying.  Even if I stop/disable the service the behavior stays the same.  I haven't tried disabling it through the registry yet.
    Friday, December 10, 2010 4:55 PM