none
Requirement 3.2 Your app must not stop responding, end unexpectedly, or contain programming errors RRS feed

  • Question

  • Hi,

    I have submitted my app to windows store. it has failed certification. In certification report they says "Opening page, start loading... then crashes." nothing else.

    I have tested it on my pc it is working fine. I am not clear now on which device they have tested it. they did not give any other detail about device configuration.

    What should i do now ?? have they tested it on ARM?? How can i simulate ARM and test my app??

    Wednesday, October 17, 2012 1:57 PM

All replies

  • Yes, maybe they tested ARM, if you dont want they test ARM, just send the file for x86 and x64 and not ARM.  I think you cant test an app like ARM in your computer, you need a tablet for that. but anyway, be sure your app dont crash in initial version, maybe you are calling an document that you need create first.. and this document dont exist.. or something like that.

    Wednesday, October 17, 2012 2:53 PM
  • Yes, maybe they tested ARM, if you dont want they test ARM, just send the file for x86 and x64 and not ARM.  I think you cant test an app like ARM in your computer, you need a tablet for that.

    If i send them file with only x86 and x64 my app will not run on tablet. and i want my app to run on tablet.

    be sure your app dont crash in initial version, maybe you are calling an document that you need create first.. and this document dont exist.. or something like that.

    If my app is loading something that is not created then it should not run on my PC too. but It is working fine.

    Wednesday, October 17, 2012 3:16 PM
  • Hi Prateek,

    When building your App, did you select your Architecture as Neutral. If so then this will mean your App will be tested on ARM. Re-package and select x86 and x64.

    Thanks

    Wednesday, October 17, 2012 6:30 PM
  • hi Mark,

    I think i have put confusing statement. I want my app to run on both tablet and PC. and i have selected architecture as neutral. When i test it on my pc it is running fine. I have doubt that they might have tested it on tablet which they did not mention in failure report. now i could not test my app on ARM. so what should i do now ?? is there any way to test my app running on ARM ??

    Thursday, October 18, 2012 11:39 AM
  • One more thing I want to mention is "I used a extended splash which shows a image for 100ms" could it be a problem ?? and again it is working fine on PC. I have tested it :)
    Thursday, October 18, 2012 11:42 AM
  • If you don't specify as x86/x64 only, they will always test on ARM.  You can order a Surface on Oct 26 to test on ARM.  That's what I'm going to do.

    Thursday, October 18, 2012 2:33 PM
  • Did you try run it on Simulator ? That will not test it on ARM but I maybe you will se what's wrong.
    Friday, October 19, 2012 1:12 PM
  • Hi Prateek,

    For now you could resubmit just for x86 and x64. If the App passes, then after Launch when ARM devices are more freely available, you can test and resubmit as an update. As for your splashscreen, you could try reducing the time its shown, but the splashscreen is better than not showing anything, but could be seen as the App not launching.

    Thanks

    Friday, October 19, 2012 10:58 PM