locked
"Error: No installed provisioning profiles match the installed iOS code signing keys" RRS feed

  • Question

  • User5676 posted

    I get the above error when trying to build my app and publish to TestFlight.

    I have gone in circles trying to clear out and recreate certificates and provisioning profiles, with no luck.

    I was able to create this successfully when using a first certificate, but as TestFlight errored out because I had no devices attached to that provisioning profile, I had to recreate the certificate. Since doing this I have encountered this error.

    Can someone give me any clues?

    Thursday, February 13, 2014 6:54 PM

All replies

  • User1044 posted

    A Provisioning Profile needs for your code signing key and your device to match the list of keys/devices that the Provisioning Profile is configured for.

    Make sure that you install the certificate and private key that the Provisioning Profile is created for into your Login keychain (use the Keychain Access app or Xcode to add it).

    Thursday, February 13, 2014 7:15 PM
  • User5676 posted

    Hi Jeffrey, thanks for your help.

    Here are the steps I went through:

    Generate a certificate request:

    Upload to Apple Dev Portal, download the certificate.

    Select it in Xamarin Project options:

    Try build, when getting to the codesigning it asks permission (is the name being "" correct?)

    However same frustrating error:

    I see in the csproj I can specify code signing attributes - should I try setting these manually? Where can I find the keys of the signing profile / certificate to do so?

    Any more tips appreciated!

    Thursday, February 13, 2014 7:48 PM
  • User1044 posted

    Right, so you created a new certificate, but did you add the certificate to the Provisioning Profile on Apple's Developer Portal and then re-download/install the Provisioning Profile?

    You need to do that.

    The Provisioning Profile you have installed on your machine was created before you created your certificate, so there's no way it can have your certificate embedded inside of it.

    If you open up ~/Library/MobileDevice/Provisioning Profiles/<guid>.mobileprovision, you'll see that it has <key>DeveloperCertificates</key> which has an array of certificates as the value. Only certificates in that list can codesign an app using that Provisioning Profile.

    Once you edit it on Apple's Developer Portal to add your certificate to that Provisioning Profile, you'll need to re-download it and install the new copy and then select that in the Project Options.

    Thursday, February 13, 2014 9:41 PM
  • User1044 posted

    (FWIW, this process is ridiculously complicated)

    Thursday, February 13, 2014 9:43 PM
  • User5676 posted

    Way cool - I'd never opened up a provisioning profile in a texteditor before.

    I managed to track it down to various projects not using the right profile, and things possibly getting mixed up because of duplicate names etc. All sorted now - thanks for your help Jeffrey, and keep up the great work :-)

    Thursday, February 13, 2014 10:14 PM
  • User1044 posted

    No problem, and glad you got it working!

    Thursday, February 13, 2014 10:46 PM
  • User1196 posted

    I have a similar situation. In Xcode Developer preferences I can see that I have valid Signing and provisioning profiles. When in Xamarin the Project Project options is grayed out. In Xamarin preferences I see a valid provisioning profile but not signing profile. I'm pretty confused.

    Monday, February 17, 2014 3:09 PM
  • User1044 posted

    Are your signing identities in your Login keychain? You can use the Keychain Access app to view your keychains.

    Tuesday, February 18, 2014 4:20 PM
  • User1196 posted

    Yes I can see them in keychain and Xcode. This is why I am confused.

    Wednesday, February 19, 2014 12:44 AM
  • User1044 posted

    Can you build ok? If so, you can safely ignore the values in the Details dialog.

    Wednesday, February 19, 2014 4:45 PM
  • User44850 posted

    I have the same issue. I went so far as to generate a new provisioning profile that used a new certificate and it's STILL barfing when I try to build via Xamarin.

    I downloaded every distribution certificate available in developer.apple.com and double-clicked it to install it in Keychain. I see the certificates there, and they all say "This certificate is valid" when I click on them.

    I popped open the provisioning profile with the GUID from the error, and under the <key>DeveloperCertificates</key> dictionary entry, it just has: <array> <data> (a giant, 30 or so line string of random characters) </data> </array>

    I'm not sure what else to check. Can you help?

    Thursday, May 15, 2014 5:19 PM
  • User14022 posted

    I had the same or similar problem.

    What I did was I deleted the provisioning profiles (off my local machine) as well as the certificates and reinstalled them. Then, even after a reboot it did not work. But to make it work I opened Xamarin and went to Preferences > Developer Accounts > [selected my account and clicked view details] > REFRESH

    After the provisioning profiles were refreshed then it had the new profiles in there and it worked again.

    Tuesday, June 10, 2014 7:28 AM
  • User6763 posted

    I upgraded Xamarin to 5.0.1. The Developer Accounts menu is no longer there. You have to refresh the provisioning profiles in Xcode. You can find more details at https://forums.xamarin.com/discussion/9923/developer-accounts-menu-item-is-missing.

    Wednesday, June 11, 2014 4:54 PM
  • User161480 posted

    Hello,

    I had the same problem in Visual Studio with a Shared Coded project. I just changed my Startup project for iOs and the error has gone.

    Thanks

    Tuesday, October 6, 2015 3:11 PM
  • User162621 posted

    Hello,

    I am having exact problem. I am creating provisioning profile for in-house distribution. First I created AppId and then I created Distribution Certificate, finally I created provisioning profile with distribution certificate. After creating profile, I refreshed Xcode and my profile was listed in that. In Xamarin under iOS Bundle Signing tab, in-house provisioning profile is listing under developer signing code, not for distribution.

    If I select Distribution (Automatic) identity, my profile is shown and if I choose my profile, its showing compile error as below:

    Error: No installed provisioning profiles match the installed iOS code signing keys

    I am able to build ipa without any error in developer signing code, but it is actually distribution profile. What could be the problem, many times I recreated certificate & profile. I am creating & opening certificate in same Mac machine only.

    Friday, October 23, 2015 4:56 AM
  • User129276 posted

    I had a similar Error message, But, I was not run my app on any physical device, I just wanted to run it on iOS simulator, the solution was simple:

    right click on your project =>properties =>Configutaion properties=>configuration =>change platform from iOS to iphone simulator

    Thursday, November 12, 2015 8:10 PM
  • User211618 posted

    What helped me was 1) reading https://developer.xamarin.com/guides/ios/gettingstarted/installation/deviceprovisioning/free-provisioning/ and 2) ensuring that Bundle Identifier of my Xamarin.Forms iOS project (specified in 'Info.plist') matches Bundle Identifier of my sample project in Xcode.

    Friday, April 8, 2016 12:08 AM
  • User239094 posted

    SOLVED: I had the same darn issue and was searching for hours for a solution. I am on free provisioning, and the dummy application I created in XCode during the free provisioning setup process (https://developer.xamarin.com/guides/ios/gettingstarted/installation/deviceprovisioning/free-provisioning/) was running on my connected iPad fine. I had checked the bundle identifier (com.xxx.yyy) in XCode and Xamarin Studio were the same in Info.plist and everything. The problem was when I tried to run my app from Xamarin Studio on the same iPad, I got an error during the build.

    TO FIX: In XCode, change the text of the bundle identifier manually to something else at the end. For example, my old one was "com.Mika.calc" and I changed it to "com.Mika.calc-" just by adding a space at the end. Immediately, a message will appear in XCode below the box you typed the text in that says "no matching profiles matching the bundle identifier were found," and below that there will be a button labelled "Fix Issue." CLICK THAT. Now, copy the new bundle identifier and paste it in the Info.plist file of your project in Xamarin Studio. Now, when you go to [yourProject].iOS > Options > iOS bundle signing everything should be fixed.

    Monday, July 4, 2016 4:40 AM
  • User201220 posted

    @MikaY said: SOLVED: I had the same darn issue and was searching for hours for a solution. I am on free provisioning, and the dummy application I created in XCode during the free provisioning setup process (https://developer.xamarin.com/guides/ios/gettingstarted/installation/deviceprovisioning/free-provisioning/) was running on my connected iPad fine. I had checked the bundle identifier (com.xxx.yyy) in XCode and Xamarin Studio were the same in Info.plist and everything. The problem was when I tried to run my app from Xamarin Studio on the same iPad, I got an error during the build.

    TO FIX: In XCode, change the text of the bundle identifier manually to something else at the end. For example, my old one was "com.Mika.calc" and I changed it to "com.Mika.calc-" just by adding a space at the end. Immediately, a message will appear in XCode below the box you typed the text in that says "no matching profiles matching the bundle identifier were found," and below that there will be a button labelled "Fix Issue." CLICK THAT. Now, copy the new bundle identifier and paste it in the Info.plist file of your project in Xamarin Studio. Now, when you go to [yourProject].iOS > Options > iOS bundle signing everything should be fixed.

    But then I probably can't use the old identifier, can I?

    Wednesday, July 6, 2016 11:26 AM
  • User239094 posted

    No, you have to change all the places the bundle identifier appears at. Forgot to mention that little step. Also, if it doesn't appear to work at first, I tried cleaning the solution. After that it usually works. I had to clean when I was changing the target and minimum Android versions in the [project].Droid options too for it to work. Generally, when I'm in doubt I clean the project just to see if that alone will fix anything first.

    Thursday, July 7, 2016 2:22 PM
  • User255066 posted

    The way I solve was create an empty app with the same name, same bundle identifier, in xcode, I run the app to the iphone, then return to visual studio and link to the provisioning profile in ios bundle secction, and run to divece

    Sunday, September 18, 2016 11:46 PM
  • User214560 posted

    @jimra said: The way I solve was create an empty app with the same name, same bundle identifier, in xcode, I run the app to the iphone, then return to visual studio and link to the provisioning profile in ios bundle secction, and run to divece

    Fantastik !!!! You saved my life !

    Warning... If your Visual Studio compilation seems to be long... Look in your mac. System ask you to allow Visual Studio to Sign your app.

    Tuesday, November 1, 2016 9:23 PM
  • User259642 posted

    I am having a similar issue. I created a sample app in Xcode and ran it to my iPhone device fine. I try it in Xamarin and error. I have the bundles the same so not sure why it works in Xcode and not Xamarin.

    I have tried all the above and I am still getting the following error:

    Installing application bundle 'com.ravenworx.pricescanner' on 'Stephen Hunter’s iPhone' ApplicationVerificationFailed: Failed to verify code signature of /private/var/installd/Library/Caches/com.apple.mobile.installd.staging/temp.5muxvP/extracted/PriceScanner.iOS.app : 0xe8008016 (The executable was signed with invalid entitlements.) error MT1006: Could not install the application '/Users/stephenhunter/Documents/Development/PriceScanner/iOS/bin/iPhone/Release/PriceScanner.iOS.app' on the device 'Stephen Hunter’s iPhone': Your code signing/provisioning profiles are not correctly configured. Probably you have an entitlement not supported by your current provisioning profile, or your device is not part of the current provisioning profile. Please check the iOS Device Log for details (error: 0xe8008016).

    Application could not be uploaded to the device.

    UPDATE I fixed this by going to the Entitlements.plist and unchecking the "Enable Keychain Access Groups", then it ran on my device like a charm.

    Wednesday, December 28, 2016 9:24 PM
  • User246651 posted

    @Amer.Radi said: I had a similar Error message, But, I was not run my app on any physical device, I just wanted to run it on iOS simulator, the solution was simple:

    right click on your project =>properties =>Configutaion properties=>configuration =>change platform from iOS to iphone simulator

    I had this issue on VS 2017 final and this solved it. I already tried so much! Thank you!

    Friday, March 10, 2017 12:55 PM
  • User261770 posted

    @"Amer.Radi" @zuckerthoben This worked after I changed, closed the solution and opened it back... Thanks !

    Tuesday, May 16, 2017 2:10 PM
  • User338509 posted

    This process is ridiculously complicated. I am not a Mac person but can get around it. I have created an account and have the certificate and it is in my login on my key chain and it is in the project file on the Windows machine with Visual Studio 2017, building a Xamarin application. Trying to compile for an iPhone, simulator stuff works fine, when compiling so I can deploy to testers get this error about provisioning file. Again have done everything mentioned about on the MacBookPro which is doing the compiling and when I miss type the certificate name on the windows machine it sees the error, etc. but when I compile I still get the No Installed Provisioning File. The X-Code application (sample) which I created has a different name than the project file I am working Windows and VS 2017. Somebody please give me step by step on this. Wasted too much time. Thanks. Don

    Wednesday, August 2, 2017 9:28 PM
  • User21936 posted

    This is pretty much a step by step:: https://developer.xamarin.com/guides/ios/gettingstarted/installation/deviceprovisioning/

    The above assumes you are a member of the paid Apple iOS developer program. It sounds like you may be using the free provisioning option? If so I do not think that will work for any device other than your own device. If you want to deploy to testers you will have to join the paid iOS developer program. If you have already paid for the iOS developer program, then the steps in the above linked guide should work.The way you mentioned XCode and the project name in XCode is what makes me think you may be using that free option, thought not nearly 100% sure.

    Thursday, August 3, 2017 12:59 AM
  • User67245 posted

    It is this kind of convoluted, controlling, asinine crap that makes me despise Apple. I would burn all of my Apple devices if I did not have customers that want iOS applications.

    Wednesday, September 13, 2017 10:33 PM
  • User300571 posted

    @MarkFuriate said: It is this kind of convoluted, controlling, asinine crap that makes me despise Apple. I would burn all of my Apple devices if I did not have customers that want iOS applications. I am having huge problems with this too and I cannot seem to find a solution. One thing keeps leading to the other and I've spent about 4 hours today trying to get a test application to build on my phone, and so far nothing has helped.

    But hey, it "just works".

    Friday, October 6, 2017 2:44 PM
  • User355508 posted

    Tried everything written on here as well as many other sites, nothing has helped. I am simply trying to deploy to the iPhoneSimulator using Xamarin on Windows with a connected Mac, and all I get is:

    error : No installed provisioning profiles match the installed iOS signing identities.

    Total and utter wind-up. All that I read says that I SHOULD NOT NEED any provisioning profile to deploy on the simulator - this is only required to deploy to a physical test device. If everyone would only use Android life would be so much easier!!

    iOS Bundle signing is set to Developer (Automatic), provisioning profile also to Automatic.

    On XCode on the mac, I can build and run a 'hello world' app in the simulator fine.

    Now thinking that I need to ditch Xamarin and just do two apps natively - the time consumed working around all of Xamarins own issues exceeds the time required to build separately for two platforms making Xamarin totally pointless!

    Nigel

    Thursday, November 9, 2017 1:47 PM
  • User74 posted

    @NigelWebber have you tried doing the same using Xamarin on the mac? This works out of the box for me, no issues at all.

    Thursday, November 9, 2017 2:33 PM
  • User355508 posted

    Just tried to build same 'hello world' project on VS on the mac - same error!

    Selected Project --> Debug|iPhoneSimulator --> iPhone 6 Result in screenshot....!

    (maybe not, cant post links)

    Will try and reinstall all the MS/Xamarin stuff on the mac.

    Thursday, November 9, 2017 4:03 PM
  • User355508 posted

    Hi

    In case someone else comes across this issue while deploying to the iPhoneSimulator, the solution was to remove (eg blank out) the 'Custom Entitlements' field under MyProject.iOS --> Properties --> iOS Bundle Signing. This is where you give your app certain entitlements - eg Siri, Push notifications - which obviously wont work when running under the simulator. A more helpful error than 'Error: No installed provisioning profiles match the installed iOS code signing keys' would have helped here eg 'specified custom entitlements invalid while executing on iPhoneSimulator' - or simply ignore this field when running on the simulator?

    Wednesday, November 15, 2017 1:02 PM