locked
Virtual Machine not connecting RRS feed

  • Question

  • Hi,

    We just entered EA with Microsoft. we took a windows server and hosted our corporate website.

    now that machine is not connecting via RDP. Website is running.

    i have tried restart, changes sizes, creating new VM with that image still no luck.

    Please help us. if you want instance details i can give.

    Sathyan

    Saturday, December 22, 2012 12:42 AM

Answers

  • Hello,

    For RDP issue, there are mainly three scenarios.

    Could not connect instance after it is initialized, in other words, RDP is not successfully from the start.

    First check you login username and password to see if it has met the password policy of Windows Server OS or not, for example, while set “User: amit123, Pass: aMit123” for RDP login in Visual Studio, it is permitted, but this username/password does not meet the password policy of Windows Server 2008 R2, after the deployment is uploaded to Azure, the login “User: amit123, Pass: aMit123” will not work in RDP and give an RDP error. So in this situation, if you username and password is not strong, you can test a standard login like “User: testadmin, Pass: test@12345”.

    if the standard login still does not work for you, that must be the problem related Azure fabric, that means the instance is not rightly initialized which causes the problem in RDP. So Azure fabric need to do some repairing for this problem instance. In this situation, you are very encouraged to contact our Azure support, then we will do the needful as soon as possible, actually, it is very very low possibility to see a problem instance in Azure fabric.

    Could not connect instance after a successful RDP or accidentally RDP terminate.

    In this scenario, the most possible is that the remote access process in certain instance is stuck because the past successful RDP session or the past RDP terminate, to solve this problem, we can reboot the instance and wait it to be fully initialized again, and after it comes to ready, try to login it, that should work.

    Never succeed in RDP even with standard login in several deployments.

    This scenario rarely happens due to client machine environment issue, such as firewall, development SDK conflicts and so on. We need do troubleshooting for this scenario by many tools, before troubleshooting, the fast way to check it is to RDP in another machine out of that same network environment.

    Thanks.


    Friday, December 28, 2012 8:04 AM