none
Users are not seeing users in the GAL after SP1 Installation

    Question

  • Users are complaining that there are no Names in their GAL after SP1 Installation. Everything was fine prior. It is not all users.
    Monday, October 11, 2010 2:12 PM
    Moderator

Answers

All replies

  • After testing the issue is occuring to all users in any organization. When I log in as administrator everything works fine (see all GALs). It is definetly an issue that arrised with SP1 Update. Does anyone have any Ideas?
    Monday, October 11, 2010 4:31 PM
    Moderator
  • Saturday, October 16, 2010 2:13 PM
    Moderator
  • Hi there,

    I can say the only problem I have had with SP1 and the GAL is that all users can see everything in the GAL's but this can take anywhere up to 48 hrs.  Any new users added are visible more or less in OWA but Outlook even after a send and receive, will take up to, again, 48 hrs.

    This I can live with and so can my users, I have stated on the website that GAL updates using Outlook can take up to 48hrs to replicate through the system.

    I have tested this over the last week and everything is fine with SP1 just a little slow. 

    Hope this helps.

    Gary

    Sunday, October 24, 2010 8:02 AM
  • I'm seeing the "All Rooms" address list in OWA after making these changes, but all the other canned Address Lists are hidden. I found the list object attribute still set to allow and tried both removing that and applying a deny on the permission but it still want's to show up.

    Any ideas?

    Monday, November 8, 2010 3:04 PM
  • Yeah I have the same issue. I havent really spent anytime trying to get rid of it, and it only seems to show up in OWA not Outlook. This seems to be the only issue I have had other than also needing to revert the Default Address Book settings for the blackberry to work then applying this logic to my BB server (Bes needs to see a GAL for all Users to work properly and the way exchnage server works is that it displays the largest GAL a user is a member of and has permission for.

    http://www.blackberryforums.com/bes-admin-corner/224842-bes-5-segregated-gal-setup-disable-lookup.html

     

    Meant to put this information up but had not had the chance. I will spend sometime when I get a chance but we have no rooms on any client, thats why it has not been an issue.


    Omar Armenteros Virtuworks
    Monday, November 8, 2010 3:12 PM
    Moderator
  • Figured out why All Rooms shows up. Exchange wants to show the resource address lists no matter what.

    How to fix
    1. Open ADSIEdit.
    2. Naviagate to the All Rooms address list.
    3. Copy the distinguishedName attribute.
    4. Open your organization object [cn=YourOrg].
    5. Look in the list of attributes for the msExchResourceAddressLists attribute.
    6. Remove the current DN which is {All Rooms DEL:47dd20dc-2efa-462b-b838-369eac589ddd}.

    Reference: http://blogs.msdn.com/b/dgoldman/archive/2007/12/05/deleting-the-all-rooms-address-list-stops-it-from-showing-up-in-owa.aspx

    Sunday, November 14, 2010 2:45 AM
  • I would like to recommend you to find and remove unneeded permissions (ADSI). Already tested "ok" on one production environment only.

    Please note, any changes on your own risk.

    It doesn't supported/confirmed by WSP http://social.msdn.microsoft.com/Forums/en-US/wspentsupport/thread/f4db8636-a3a3-4c1c-93dd-82390f9d1d8f

    Thanks.

     


    Best regards, Dmitry Fitsner Support@ExpertServices.us | WebsitePanel Installations, Support & Consulting | Enterprise Solutions Planning & Deployment & Support
    Tuesday, November 16, 2010 10:32 PM
    Answerer
  • Hello Omar,

    your wrote on your blog:

    ====================================
    You need to create two rules on the following sub-DN of "Address Lists container" (Also make sure "Include inheritable permssions" is checked as well)

    All Contacts
    All Groups
    All Rooms
    All Users
    Public Folders
    All Global Address Lists
    Offline Address Lists
    ====================================

    "Offline ALs" does not contain a permission entry "Open Address List".
    Can you clarify?

    Thx in advance!
    Marcus.



     

    Wednesday, December 29, 2010 8:24 PM