none
VS Android Emulator cannot boot

    Question

  • Hi everyone. I'm trying to get Android Application using VS 2015 and when I try to run it, I can see VS Android Emulator launching but then it gets stuck (Starting OS) and never finishes booting.

    I've run Hyper-V Administration tool and took a look to the emulator console, this is the last message I get:

    "init: Failed to read from /dev/hw_random: No such device"

    Any clue?

    Tuesday, May 05, 2015 11:43 AM

Answers

  • I've found the problem.

    I was running Windows 10 from VMWare, and it seems that OpenGL visualisation in VS Android Emulator is not supported under VMWare.

    It can be disabled by going to Program Files (or Program Files x86 if you're on a 64-bit machine)\Microsoft XDE\10.0.0.0\SKUs\Android\xdesku.xml and deleting this line: GuestDisplayProvider="VsEmulator.OpenGLGuestDisplay".

    However, without OpenGL turned on you won't be able to take advantage of many of the new features, and it will be really slow.

    • Marked as answer by FDF Dev Wednesday, May 06, 2015 9:05 AM
    Wednesday, May 06, 2015 9:05 AM

All replies

  • Hi theopulus,

    Thank you for posting in MSDN forum.

    Because VS2015 is still a preview version instead of final released version, Isuggest that you should submit this feedback to Microsoft Connect feedback portal: http://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx, Microsoftengineers will evaluate them seriously.

    After you submit the feedback, you can post the link here which will be beneficial for other members with the similar issue.

    Thanks for your understanding.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, May 06, 2015 6:26 AM
    Moderator
  • I've found the problem.

    I was running Windows 10 from VMWare, and it seems that OpenGL visualisation in VS Android Emulator is not supported under VMWare.

    It can be disabled by going to Program Files (or Program Files x86 if you're on a 64-bit machine)\Microsoft XDE\10.0.0.0\SKUs\Android\xdesku.xml and deleting this line: GuestDisplayProvider="VsEmulator.OpenGLGuestDisplay".

    However, without OpenGL turned on you won't be able to take advantage of many of the new features, and it will be really slow.

    • Marked as answer by FDF Dev Wednesday, May 06, 2015 9:05 AM
    Wednesday, May 06, 2015 9:05 AM
  • Hi theopulus,

    I am glad that you have solved the problem and thanks for your share us the solution here, so it would be helpful for other members who get the same issue.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, May 06, 2015 11:15 AM
    Moderator
  • This is is fixed in VMware Fusion 8. I think I should get fixed on lastest version of VMware Workstation as well.
    Wednesday, August 26, 2015 3:02 AM
  • Was this ever resolved, I am using both the release version of visual studio and Windows 10 but still get the error.

    John J. Hughes II

    Sunday, January 17, 2016 3:19 AM
  • Was this ever resolved, I am using both the release version of visual studio and Windows 10 but still get the error.

    John J. Hughes II

    Yes i am also using both visual studio and win10. But i couldnt fix this problem.
    Wednesday, August 17, 2016 7:37 AM