locked
Unable to Generate key for a WEB API application in Azure Active Directory RRS feed

  • Question

  • Hi, 

    Each time i try to generate Key for my application. 

    I get an error however on refreshing the page , the key is added but it is hidden.

    I am unable to copy the key.

    Any pointers for resolving this.

    Thanks 

    Sunday, March 23, 2014 7:23 AM

All replies

  • Any pointers , i am stuck on this issue and can't get ahead with development.
    Sunday, March 23, 2014 5:49 PM
  • I had the same problem and I solved it by deleting the current application and creating a new one. In the new application, you can get keys as well as modify permissions. 
    Wednesday, March 26, 2014 12:55 PM
  • The fix for this issue should go out into production today or tomorrow.  Sorry for the inconvenience.

    In the meantime the workaround (cryptically) is to go to the Application Permissions you gave your app to the Graph API (Windows Azure AD), and remove them, save, and re-add them.  Then you should be able at add your key.

    Hope this helps,


    Dan Kershaw [msft]

    Friday, March 28, 2014 12:39 AM
  • Hello

    I'm still having this issue, tried the work-around Dan suggested but still no luck.

    Is there any other work-around or solution to this problem?

    Thank you for your time.

    -VK

    Wednesday, November 18, 2015 6:28 PM