none
Phantom messages causing timeout exceptions on ASB

    Question

  • Was directed here via @AzureSupport via Twitter.

    When I enable "Break when thrown" in visual studio, I see that timeout exceptions are being thrown by the service bus library I am using (WindowsAzure.ServiceBus 3.4).  Since I only notice when "break when thrown" is enabled, it must be handled within the library, so this is not a fatal exception.

    As far as I can tell, there are no pending messages for any of my subscribers, nor any messages in the dead letter queue (this is dev).  I suspect that these messages are for a subscriber that had been deleted and recreated weeks ago.  My concerns are 1) am I doing something wrong (I don't think I am) and 2) in production, under load, would this sort of thing be a problem?

    Below are the exception details, except for the endpoint name, which I've replaced with XXXX

    System.ServiceModel.FaultException`1 occurred
    Message: Exception thrown: 'System.ServiceModel.FaultException`1' in Microsoft.ServiceBus.dll
    Additional information: A timeout has occurred during the operation. TrackingId:6e7ee1f8-14c5-40a5-aeb7-998d826e16f1_G25_B23, SystemTracker:XXXX:Topic:user-changed|identity, Timestamp:1/5/2017 3:32:35 PM
    Thursday, January 05, 2017 4:32 PM

All replies

  • I don't think you need to worry. Service Bus has some internal implementation that relies on exception contracts. This must be one of them. Can you confirm that your Receive call is returning null? If so then everything is fine.
    Thursday, January 05, 2017 5:12 PM
  • Yes recieve isn't returning anything, and NamespaceManager.CreateFromConnectionString(_connectionString).MessageCount returns 0

    • Proposed as answer by Prakash Bhanu Thursday, February 02, 2017 7:19 AM
    Thursday, January 05, 2017 7:36 PM
  • Sounds Ok. Let us know if you have any other questions.
    Tuesday, January 10, 2017 9:55 PM
  • Is there any way to get rid of these messages? They are cluttering our debug output like crazy, as they fire off every 30 seconds.
    Monday, March 13, 2017 5:58 PM
  • Make sure "Just My Code" is enabled from Debugging Options on Visual Studio. It sounds like you are running that unchecked.
    Monday, March 13, 2017 6:13 PM
  • Looks like that did it! Thank you for the prompt reply Serkant.
    Monday, March 13, 2017 6:16 PM