locked
Client Certificate Validation with Infopath 2007 RRS feed

  • Question

  • Open infopath click on Design a Form Template > Ok. Now go tools> Data Connections > Add > Create a new coonection to "Recieve Data"> OK.  WebService > enter the web service (Example: http://www.contezo.comz/Service.asmx?WSDL ) Click on next if you can.

    The first time someone trys to make the above data connection it works. I am thinking becuase it prompts for a Client certificate.

    The second time they attempt to do the above it then fails. The form is not asking for a client certificate.

    Is there a way to have Infopath request a certificate and or not store a recently used one.

    Just frustrating that a person can create a data conection the first time on a new form. Then after the first time, the user can not create the same data connection.

     For a brief moment in IIS on the virtual directory containing the webservice, we set the option from "Require Client Certificates," to "Ignore Client Certificates" and it worked. One small problem it is against policy to turn off client authentication. So turned Client Authentication back on, now data connections do not work.


    R/ Art M
    Thursday, July 14, 2011 9:07 PM

Answers

  •   I created a local copy name.wsdl . In the data connection wizard when asked for the url one would place the path of which they saved the file at. In my case it would be file:///d:/name.wsdl .  Yes I know this does not solve the certificate issue. This does solve my problem that I cant get to the wsdl. I can now create my form with the data connections. Time to publish and work with that.
    R/ Art M
    • Marked as answer by Arthur M Wednesday, July 20, 2011 8:54 PM
    Wednesday, July 20, 2011 8:54 PM

All replies

  • Hi Art,

    What happened preventing people from trying to create another data connection of Web Service type?
    I think it's the default behavior that it prompts for user credential when people first connect to the web service and then it remember the credential later on.

    Thanks & Regards.

    Lily Wu
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.
    Friday, July 15, 2011 1:42 PM
  • What is happening is this, I open infopath to create a new form. Then I add a data connection, during the creation of the data connection I am prompted for my certificate this works fine. As soon as I attempt to create another new form with that exact same data connection. Infopath does not prompt me for my certificate information. I then get "Could not open "web service URL". 

    The question is how do I have infopath request my Certificate now. Or better yet where is the Certificate information stored at. I have attempted to solve this looking at places that cache information. I.E. Browser, Info Path cache, Server IIS settings. I have had at least five people attempt this and everyone gets the same result. On first try they are able to connect to the data connection. On second attempt infopath does not prompt for a certificate so the user is not validated. Thus the data connection is denied. I checked the web log on the IIS server and shows a 405 error. We are currently using NTLM for authentication. The web service works via my browser just fine. Its when I use Infopath 2007 that I am having the problem because its not prompting me for my certificate.


    R/ Art M
    Friday, July 15, 2011 2:11 PM
  • Any suggestions on who to ask or book to read?


    R/ Art M
    Monday, July 18, 2011 10:00 PM
  • Hi Art,

    I've involved someone familiar with this to further look into this issue and there might be some time delay.

    Thank you for your patience.

    Regards.

    Lily Wu
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 19, 2011 1:03 AM
  •   I created a local copy name.wsdl . In the data connection wizard when asked for the url one would place the path of which they saved the file at. In my case it would be file:///d:/name.wsdl .  Yes I know this does not solve the certificate issue. This does solve my problem that I cant get to the wsdl. I can now create my form with the data connections. Time to publish and work with that.
    R/ Art M
    • Marked as answer by Arthur M Wednesday, July 20, 2011 8:54 PM
    Wednesday, July 20, 2011 8:54 PM
  • Hello Arthur,

    Can you apply this hotfix to see if it resovles your issue?

    http://support.microsoft.com/kb/980213

    I look forward to your reply.

    Regards,

    AmandaRu-MSFT


    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, July 25, 2011 7:17 PM
  • Hello Arthur,

    Do you try applying the hotfix in the above posting?  If so, did it resolve your issue?

    Regards,

    AmandaRu-MSFT


    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, August 3, 2011 8:16 PM