none
Cannot install .net framework RRS feed

  • Question

  • Hi,

    I've have tried everything to install .net framework and nothing has worked :(.

    Things I have tried:

    All Solutions from a link in this site but I can't link it.

    I tried a method on a Youtube video titled: How to fix failed install code Error HRESULT 0xc8000222 .net framework 4.0

    I've deleted %temp%, attempted to install an earlier version,

    Tried Windows Update but nothing seems to work...

    When I do try to install it instantly fails and I get this error code: HRESULT 0x8000247

    Anyone got some help for me?

    Sunday, December 1, 2013 7:07 PM

Answers

All replies

  • Hi,

    Please clarify your OS version.

    Do you want to install .Net Framework 4.0?

    If your OS version is win8 or higher, the .Net Framework4.5(include 4.0) is a part of OS. Have be installed in OS.

    you could open “Control Panel”->”Programs”->”Turn Windows features on or off” and open “.NET Framework 4.5 Advanced Services”

    If your OS is not win8 or higher, please follow these steps:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0 or 4.5:

    .NET Framework 4.0:http://www.microsoft.com/en-us/download/details.aspx?id=17718

    .NET Framework 4.5:http://www.microsoft.com/en-us/download/details.aspx?id=30653

    NOTE:.Net Framework 4.5 includes .Net Framework 4.0. .Net Framework4.0 support win XP SP3 and win Vista sp1 or higher. But .Net Framework 4.5 don't support win XP, and support win vista sp2 or higher

    2. Also, clear your %temp% directory and disable your AV software.

    3. Run the installer from step 1 As Administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload the file to https://skydrive.live.com/ and share the link here.

    The complete log set is needed for analysis.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, December 2, 2013 8:16 AM
  • Hi,

    I believe these are the files you are looking for:

    https://skydrive.live.com/redir?resid=D6BE4B11AA7A256C%21300

    Regards,

    Monday, December 2, 2013 9:58 PM
  • From your log:

    Launching CreateProcess with command line = wusa.exe "C:\c345ec04e46a088d08c1d38f\Windows6.1-KB958488-v6001-x64.msu" /quiet /norestart
    [12/1/2013, 18:48:35]Exe (C:\c345ec04e46a088d08c1d38f\Windows6.1-KB958488-v6001-x64.msu) failed with 0xc8000247 - (null).
    [12/1/2013, 18:48:35]PerformOperation on exe returned exit code 3355443783 (translates to HRESULT = 0xc8000247)

    It appears that your Windows Update service is failing. You can try the suggestions in Alexander Sun's answer in this thread:

    http://social.msdn.microsoft.com/Forums/vstudio/en-US/d8f59074-dc4e-43fb-b713-995119c9a5f6/net-framework-setup-failed-with-0x8000247?forum=netfxsetup

    • Marked as answer by Apridding Wednesday, December 4, 2013 10:01 PM
    Tuesday, December 3, 2013 3:45 PM
  • I tried activating Windows Updates again, nothing.

    I thought that maybe the problem lay with IRRT, but while updating it stopped with a fatal error.

    I may try to repair windows but I cant do that until I go home from uni in a few weeks.

    Anything else I can do until I repair?

    • Marked as answer by Apridding Wednesday, December 4, 2013 10:01 PM
    • Unmarked as answer by Apridding Wednesday, December 4, 2013 10:01 PM
    Tuesday, December 3, 2013 8:25 PM