none
Reportviewer and all its VERSIONS! Oh, and Print Layout problems, too! RRS feed

  • Question

  • Can anyone identify which versions of all the Reportviewer DLLs and EXEs work together well?  For example, when I have an application include the Reportviewer.exe in the ClickOnce install path, the Reportviewer.exe version that is currently being added to my DEPLOY path is 2.0.50727.42 (which IS the same as the version in my v2.0\bootstrapper\packages\reportviewer directory).  So most of my users are running this Reportviewer version. 

    On the development side, in BIDS, when I run an app with the Reportviewer control some of the ReportingServices DLLs that appear to be running on my local PC are:

     

    Microsoft.ReportingServices.ReportPreview - version 9.00.3042.00

    Microsoft.ReportingServices.ProcessingObjectModel - version 9.00.1399.00

    Microsoft.ReportingServices.ProcessingCore - version 9.00.3042.00

     

    If I install the app on my local PC and run it, these DLLs appear to be running:

     

    Microsoft.ReportViewer.Common.DLL - version 8.0.50727.817

    Microsoft.ReportViewer.WinForms.DLL - version 8.0.50727.817

    Microsoft.VisualBasic.NI.DLL - version 8.0.50727.42(RTM .050727-4200)

    I don't see ReportViewer.exe running on my PC.

    A possibly(?) related DLL also running is:

    Microsoft.ReportViewer.Common.DLL - version 8.00.50727.762

     

    To make matters more confusing, in my C:\Program Files\Microsoft Visual Studio 8\ReportViewer directory I have only these "ReportViewer" DLLs:

    Microsoft.ReportViewer.Common - version 8.00.50727.762

    Microsoft.ReportViewer.WinForms- version 8.00.50727.762

    Microsoft.ReportViewer.WebForms- version 8.00.50727.762

     

    At this point, I'm not comfortable that what I see when I am testing in BIDS is the same as what the users will see when they install the app.  AND, ONE (of several) of the problems that initiated my checking all these versions is related to the Print Layout button on the Reportviewer window.  It used to work great, but after all this installing/uninstalling/reinstalling/upgrading and development vs. deployed app, the Print Layout now appears mostly blacked out with partial text showing and any report bigger than portrait width is printing with blank pages between report pages.

    Any help is appreciated.

     

    Dawn

     

     

    Wednesday, September 5, 2007 8:48 PM

All replies

  • After searching this forum all afternoon, then posting this problem, I went to the SQL Server Reporting Services forum and actually found a post on how to fix the black Print Layout background problem.  The problem appeared after SQL SP2 and there is now a cumulative hotfix that will fix the problem.  Here's a link to that information:

     

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1379858&SiteID=1

     

    As far as all the versions, I would still like to see or find a list somewhere that explains which versions go with which versions for all the reportviewer and reporting services DLLs in my original post.

     

    Thanks,

    Dawn

     

    Wednesday, September 5, 2007 9:49 PM