none
EDIFACT with no UNA RRS feed

  • Question

  • Hi guys!

    I'm going nuts. I receive a file with no UNA, and uses comma for decimal delimiters, and of course i get an event in ev. viewer saying that the system cannot process 20,5 for example. Of course if i change the comma for the point it works perfectly.

     

    How can I set the decimal symbol if I don't have the UNA?

     

    Thanks!

    Victor

    Monday, July 23, 2007 7:36 PM

Answers

  • UNA is an optional segment, and if not present in the instance, the delimiters would be read from receive pipeline property. You would have to change the decimal separator to whatever it is in the instance (in this case a comma) and try again.

     

    Let me know if this helps

     

    Thanks

    Mohsin 

    Monday, July 23, 2007 11:24 PM

All replies

  • UNA is an optional segment, and if not present in the instance, the delimiters would be read from receive pipeline property. You would have to change the decimal separator to whatever it is in the instance (in this case a comma) and try again.

     

    Let me know if this helps

     

    Thanks

    Mohsin 

    Monday, July 23, 2007 11:24 PM
  • Absolutely, you know I've been through the pipeline properties several times, but since I saw hex codes, I didn't relate that to the limiters.

     

    So, all I have to do is thank you for pointing me in the right direction.

     

    Thanks Mohsin!

    Victor

    Tuesday, July 24, 2007 12:24 AM
  • Hi

    To Remove/Add the UNA segment uncheck the Apply UNA Segment.

    Goto Parties--> Agreement --> Second Tab under Click on envelopes.


    Regards, Aboorva Raja R Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, February 19, 2016 6:44 PM