locked
Parser Error RRS feed

  • Question

  • User-1711277176 posted

    2008 Server Standard IIS 7.0

    Here is the eeror I am getting....anyone have any idea's?

    Server Error in '/' Application.

    Parser Error

    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

    Parser Error Message: Could not load type 'Intranet.WebForm1'.

    Source Error:

    Line 1:  <%@ Register TagPrefix="iewc" Namespace="Microsoft.Web.UI.WebControls" Assembly="Microsoft.Web.UI.WebControls, Version=1.0.2.226, Culture=neutral, PublicKeyToken=31bf3856ad364e35" %>
    Line 2: <%@ Page Language="vb" AutoEventWireup="false" Codebehind="Tree.aspx.vb" Inherits="Intranet.WebForm1"%>
    Line 3: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    Line 4: <HTML>

    Source File: /Intranet/Tree.aspx    Line: 2


    Version Information: Microsoft .NET Framework Version:2.0.50727.4200; ASP.NET Version:2.0.50727.4016

    Sunday, December 6, 2009 10:47 PM

Answers

  • User572212476 posted

    ninmot

    I think the problem is because you have the attributes Codebehind and Inherits in the @ Page directive and you dont have a codebehind file, I recommend you to remove these attributes of the @ Page directive and try again.

    You can read more of this subject in the next link.

    http://support.microsoft.com/kb/312311/en-us

    Please tell me if this helps you to solve your problem.

    Greetings.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, December 7, 2009 11:36 AM

All replies

  • User-1659704165 posted

    Hi,

    Have tried setting the Dotnet Framework in IIS

    Run-->inetMgr-->Virtula dir-->Right Click Propties-->Asp.net tab select the Right dotnet fraemwork for Your App

    OR

    Aspnet_regiis

    http://msdn.microsoft.com/en-us/library/k6h9cz8h%28VS.80,printer%29.aspx

    Monday, December 7, 2009 12:49 AM
  • User572212476 posted

    Hi ninmot

    Can you show us the code that is in the Tree.aspx.vb file?

    Greetings. 

    Monday, December 7, 2009 1:20 AM
  • User-1711277176 posted

    Here is what is in tree.apsx....


    <%@ Register TagPrefix="iewc" Namespace="Microsoft.Web.UI.WebControls" Assembly="Microsoft.Web.UI.WebControls, Version=1.0.2.226, Culture=neutral, PublicKeyToken=31bf3856ad364e35" %>
    <%@ Page Language="vb" AutoEventWireup="false" Codebehind="Tree.aspx.vb" Inherits="Intranet.WebForm1"%>
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML>
        <HEAD>
            <title>Folder List</title>
            <meta content="Microsoft Visual Studio .NET 7.1" name="GENERATOR">
            <meta content="Visual Basic .NET 7.1" name="CODE_LANGUAGE">
            <meta content="JavaScript" name="vs_defaultClientScript">
            <meta content="http://schemas.microsoft.com/intellisense/ie5" name="vs_targetSchema">
        </HEAD>
        <body>
            <form id="Form1" method="post" runat="server"><font face="arial" size="2"><a Target="main" href="Start.htm">
                        WDL Intranet Home Page</a></font>
                &nbsp;&nbsp;<a href="javascript:parent.main.focus();window.print()"><img src="print.bmp" border="0" alt="Click to print the current document"></a><br>
                <iewc:treeview id="TreeView1" runat="server" BorderStyle="None" SelectExpands="True" EnableViewState="False">
                    <iewc:TreeNodeType ImageUrl="closed.bmp" SelectedImageUrl="open.bmp" DefaultStyle="font:10 pt arial;" Type="Folder"></iewc:TreeNodeType>
                    <iewc:TreeNodeType ImageUrl="file1.bmp" SelectedImageUrl="file2.bmp" DefaultStyle="font:10 pt arial;" Type="File"></iewc:TreeNodeType>
                    <iewc:TreeNodeType ImageUrl="adobe1.bmp" SelectedImageUrl="adobe2.bmp" DefaultStyle="font:10 pt arial;" Type="Adobe"></iewc:TreeNodeType>
                    <iewc:TreeNodeType ImageUrl="word1.bmp" SelectedImageUrl="word2.bmp" DefaultStyle="font:10 pt arial;" Type="Word"></iewc:TreeNodeType>
                    <iewc:TreeNodeType ImageUrl="picture1.bmp" SelectedImageUrl="picture2.bmp" DefaultStyle="font:10 pt arial;" Type="Picture"></iewc:TreeNodeType>
                </iewc:treeview>

            </form>

        </body>
    </HTML>


    Monday, December 7, 2009 8:16 AM
  • User-1252206308 posted

    Hi,

    Make sure that the class webform1 is in namespace Intranet in aspx.cs or remove the namespace Intranet in aspx

    <%@ Page Language="vb" AutoEventWireup="false" Codebehind="Tree.aspx.vb" Inherits="WebForm1"%> //Like this

    Hope this helps.

    Monday, December 7, 2009 8:44 AM
  • User-1711277176 posted


    Any other idea's?

    Monday, December 7, 2009 9:11 AM
  • User572212476 posted

    Hi

    Can you show us the code that is in the code behind of the file that you already posted? Must be the file with the vb extension.

    Greetings.

    Monday, December 7, 2009 9:29 AM
  • User-1711277176 posted

    I do not see a tree.aspx.vb file

    Monday, December 7, 2009 10:06 AM
  • User572212476 posted

    ninmot

    I think the problem is because you have the attributes Codebehind and Inherits in the @ Page directive and you dont have a codebehind file, I recommend you to remove these attributes of the @ Page directive and try again.

    You can read more of this subject in the next link.

    http://support.microsoft.com/kb/312311/en-us

    Please tell me if this helps you to solve your problem.

    Greetings.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, December 7, 2009 11:36 AM