locked
Error Regarding Report Viewer RRS feed

  • Question

  • Hi,

    This is Amit Gupta(System Administrator and programmer)

    I have following Configuration in test environment.

    Sql Server 2008 R2 Developer Edition, with reporting services, native mode, mixed mode sql authentication.

    visual studio 2005, .net framework 1.0, 2.0, 3.0, and 3.5 power shell, windows installer 4.5

    All the configuration is on one server which is also a domain controller, IIS server, DNS server, Sql server 2008 R2 Server.

    Environment is like this.

    My Test Server ---> Firewall --- > Internet

    My Test Server<--- Firewall <--- Internet

    I have configured all the things regarding reporting services and i can access the reporting services through URL locally as well as on internet(By HostHeader). It ask for user name and password. I have one Builtin user in the name of guestd which don't have password. and i can access But now i want to access reporting service through report viewer in Asp Dot Net Application when i give the server url(eg.http://www.abc.com/Reportserver_MSSQLServer1) and report path(eg./report/Student list) and i executes the application locally it is working fine but when i want to deploy my application on web than i am getting this error.

    The permissions granted to user 'NT AUTHORITY\NETWORK SERVICE' are insufficient for performing this operation. (rsAccessDenied)                                                                                                                                                                                                                                                        And when i add the new group in report manager through new role assignment(Builtin\Users) which is a builtin group. than i am getting this error.                                                                                                                                                                                                                                   An error has occurred during report processing.(rsProccessingAborted) cannot create a connection to data source 'DataSource1'. (rsErrorOpeningConnection) For more information about this error navigate to the report server on the local server machine, or enable remote errors.                                                                                                                                                                                         Thanks in advance, Please help me. how to i can solve this problem. I think it is problem related to permissions but i don't have the knowledge about reporting services permission. I have knowledge about sql permission but how to i can use.



    Thursday, August 4, 2011 5:21 AM

Answers

  • Hi Amitashwar,

    Thanks for posting your question here.

    Based on your description, I understand that you are using MicrosoftReportViewer control to display a server report in a custom web application. When you would like to deploy the application to IIS the error displays.

    Since the web application is on the same server as the Reporting Services web service, the call will authenticate using Default Credentials, but you are probably seeing the “permissions are insufficient” exception.

    In order to resolve this issue, I would recommend you enable impersonation for the application, for a subdirectory of pages, or for individual pages, using the identity element in web.config (see more resources for additional information). When using impersonation, it is important to deny access to anonymous users, as shown below:

                       

    <system.web>

        <authentication mode="Windows"/>

        <identity impersonate="true"/>

        <authorization>

            <deny users="?"/>

            <allow users="*"/>

        </authorization>

     </system.web>

     

    For more detail information, please reference this blog: Authentication, Role-based Security, and SQL Reporting Services Web Services.

    Hope it helps you. If the issue still exists, please let me know.

    Thanks,
    Sharp


    Please remember to mark the replies as answers if they help you and unmark them if they provide no help.
    • Proposed as answer by Sharp Wang Friday, August 12, 2011 4:35 AM
    • Marked as answer by Challen Fu Saturday, August 13, 2011 6:50 AM
    Tuesday, August 9, 2011 6:01 AM