locked
Third-party Smart Device SDK not available in VS 2008 RRS feed

  • Question

  • Hello.

     

    We use two third-party Windows CD 5 SDKs in our project (for customized Windows CE 5 devices).

    After installing these SDKs, they normally appear in VS 2005, but none of them in VS 2008.

     

    Please, where is the problem?

     

    I have read about problems with installing Windows CE 6 SDK.

    I tried to install our third-party SDKs after installing VS 2008, also I tried to repair the installation of these SDKs.

    No success.

     

    Could anyone help me?

     

    Thanks,

    Mareq

    Wednesday, July 23, 2008 9:32 AM

Answers

All replies

  • Uff, uff.

     

    I installed also VS 2005, uninstalled and installed again the mentioned SDKs, and they do not appear in VS 2005 also.

     

    But on my previous PC (Win XP 32-bit) they appeared in VS 2005, but not in VS 2008.

    On my colleagues PC (the same as mine) - Win Vista 64-bit, it is working OK - but he has only VS 2005.

     

    So here are my steps to reproduce:

     

    1. I have Windows Vista 64-bit Ultimate

    2. Installed VS 2008 (32-bit).

    3. Installed third-party WCE 5.0 SDKs.

    4. They do not appear in VS 2008 Smart Device development (when used new MFC Smart Device Application wizzard).

     

    5. Installed VS 2005 (32-bit).

    6. Uninstalled both SDKs.

    7. Installed both SDKs again.

    8. They do not appear in VS 2005 either.

     

    Please, could anyone help me?

    Thursday, July 24, 2008 7:39 AM
  • Uff, uff Sad

    I have been stuck with this problem for more then one week.

     

    Please could anybody help me.

     

    I tried also this scenarios.

     

    1. Uninstalled custom WCE 5.0 SDKs.

    2. Uninstalled VS 2008.

    3. Uninstalled VS 2005.

    4. Deleted all CoreCon directories.

    5. Installed VS 2005 only.

    6. Installed custom WCE 5.0 SDK (third-party).

    7. Started VS 2005, tried to create new MFC Smart Device Application project, when set name of the project I was unable to get to the new project wizzard. When I tried to create new ATL Smart Device Project it shows me an JS (i think so) error.

    8. So I installed also VS 2005 SP1.

    9. Now I was able to get to create new MFC Smart Device App, but my custom SDKs were not present in the Platforms "tab" of the wizzard. Only Smartphone 2003 and Pocket PC 2003, that were shipped with VS 2005.

     

    PLEASE, HELP ME! Sad

    I don't want to reinstall the whole operating system.

     

     

    On my colleagues PC (also Vista 64 bit) it works ok.

    His scenario was:

     

    1. He installed VS 2005.

    2. He installed VS 2005 SP1.

    3. He installed custom WCE 5.0 SDKs.

     

    And everything was ok on his computer.

    Friday, July 25, 2008 3:27 PM
  • Great!

     

    Finally, I have found the solution.

    All I needed was to turn off UAC (User Account Control).

    http://www.mareq.sk/2008/07/problem-installing-additional-smart.html

     

    Mareq

     

    Friday, July 25, 2008 9:18 PM