none
Can the test-indicator element be suppressed? RRS feed

  • Question

  • Is it possible to suppress the test-indicator element? (if it's not a test ofcourse)

    So the UNB looks like this

    UNB+UNOA:1+AAAAA+BBBBB+080407:1631+16

    not like this

    UNB+UNOA:1+AAAAA+BBBBB+080407:1631+16++++0

     

     

    Isabelle

     

    Monday, April 7, 2008 2:54 PM

Answers

  • There is no config setting to suppress this value. The field is populated explcitely since it is not costly for anyone and a good indicator for systems that move from test to production and keep looking at this value

     

    If you have a big business impact, let us know!

     

    Monday, August 4, 2008 1:02 PM
    Moderator

All replies

  • There is no config setting to suppress this value. The field is populated explcitely since it is not costly for anyone and a good indicator for systems that move from test to production and keep looking at this value

     

    If you have a big business impact, let us know!

     

    Monday, August 4, 2008 1:02 PM
    Moderator
  • Hi,

    Isabelle, what you are referring to is not the test indicator, it is the UNB9, Acknowledgement request. This has the default value of "0" but can be set to <Not valued> in the EDI properties dialogue, which removes this field from the UNB-segment. The test indicator is only present if you check the "UNB11 Test indicator"-box in the same dialogue (it then has the value "1" to indicate a test interchange).

    To summarize: In contrast to the answer supplied by Ravi above, both the ack request and the test indicator can in fact be configured so that they won't appear in the UNB segment.

    Regards
    Klas Ericsson
    Tuesday, November 24, 2009 10:13 AM
  • Hello, I'm using biztalk 2010 and having the same problem...there is no option to set the default value to <Not valued>.

     

    My clients are refusing my invoic's because off the existence off a zero "+INVOIC++0+EANCOM+0'"

    Can someone provide some help on this!?

     


    NB
    Monday, November 8, 2010 11:03 AM
  •  

    I am facing same problem. give some sample or any thing

    Thursday, February 2, 2012 10:12 AM
  • I'm having the same problem with the fields UNB9 and UNB11.

    This began happening after upgrading my application to the BizTalk 2006 BizTalk 2010

    Anyone know if it exists as configure UNB9 (Acknowledgement Request) in BizTalk 2010?

    I believe that if you can set this field to "<Not Valued>" the problem will be solved.


    • Edited by Tiago Lemes Wednesday, July 25, 2012 2:36 PM
    Wednesday, July 25, 2012 2:35 PM