none
Biztalk receive port with commerce server adapter is not checking the order web service web.config configurations. RRS feed

  • Question

  • My biz talk application using commerce server adapter and calling commerce server order web service to poll the order data from DB. I have SearchResultsLimit specified as value 2 in order web service Web.config file. My receive location have fixed interval of 2 minutes. When I enable the receive location the biztalk is polling all the new orders instead of 2 orders according to the SerachResultLimit configuration.  I tried changing the values "One order per message" and "multiple order per message" but still the Biztalk receive location is polling all the new orders. How to make the SearchResultLimit function work when we use commerce server adapter from Biztalk.

     

     

    Thursday, November 3, 2011 8:08 PM

Answers

  • Unfortunately, those host throttling settings will not predictably help you throttle the Commerce Server adapters.

    You probably need to queue the messages to MSMQ or some other queue so you can handle processing the load. Or perhaps send the orders to a database and have processing go from there.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Monday, November 7, 2011 9:06 PM
    Moderator

All replies

  • In searching for that config parameter, I am only seeing information about it with the profiles web service config, not the orders web service config. Do you have any documentation that this setting works with the orders web service?

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Friday, November 4, 2011 4:02 PM
    Moderator
  • Thanks for the reply.

    I did not saw any documentation for order web service and the configuration is not working as well. But the value was present with the default configuration file in orderWebService.

     

    What am trying to achieve is below.

    Currently my biz talk order app is polling 500 order per minute and which my Biztalk back end cannot accept.  How can I make it poll to 250 order per minute. IF I change the throttling settings like Maximum number of messaging engine threads per CPU and Rate over drive factor will that have any consequence on overall biztalk application performance. I am running my receive location with a separate host instance and my orchestration and send ports are working in separate hot instances.

     


    Monday, November 7, 2011 7:03 PM
  • Unfortunately, those host throttling settings will not predictably help you throttle the Commerce Server adapters.

    You probably need to queue the messages to MSMQ or some other queue so you can handle processing the load. Or perhaps send the orders to a database and have processing go from there.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Monday, November 7, 2011 9:06 PM
    Moderator