locked
Unable to connect to ASP.NET site when run locally through Visual Studio RRS feed

  • Question

  • User-361444694 posted

    I have an ASP.NET web app. It has a CMS web application which I want to run on IIS(through Visual Studio). It's .csproj file lists the project URL as https://localhost:27251/.

    I created a site on IIS which sets the physical path to the CMS root folder. This contains a Default.aspx and web.config etc.

    As it uses SSL I assigned the cert to the site in IIS.

    When I run my application in Visual Studio, a Chrome window opens at https://localhost:27251/ but the following is loaded:

    https://i.stack.imgur.com/hKUQz.png

    How do I go about resolving this?

    I suspect it's related to my host binding in IIS. This is my site binding:

    https://i.stack.imgur.com/iyNnP.png

    I generated a bindings report with Jexus Manager. Here's the output:

    IMPORTANT: This report might contain confidential information. Mask such before sharing to others.
    -----
    System Time: 11/8/2020 11:34:45 AM
    Processor Architecture: AMD64
    OS: Microsoft Windows NT 10.0.14393.0
    Server Type: IIS Express
    -----
    This machine has 2 IP addresses to take external traffic.
    * 172.16.1.5.
    * 198.19.175.62.
    -----
    [W3SVC/2]
    ServerComment  : CMS
    ServerAutoStart: True
    ServerState    : Stopped
    
    BINDING: https *:443:cms.jobzone.local
    Jexus Manager is not running as administrator, so TCP reserved port range is not verified. Please run "netsh int ipv4 show excludedportrange protocol=tcp" at command prompt to see if any conflict exists.
    URL reservation https://cms.jobzone.local:443/ is missing. So this binding only works if IIS Express runs as administrator.
    This site can take external traffic if,
     * TCP port 443 must be opened on Windows Firewall (or any other installed firewall products).
     * Requests from web browsers must be routed to following end points on this machine,
       * 172.16.1.5:443.
       * 198.19.175.62:443.
    This site can take local traffic at 127.0.0.1:443.
    This site can take local traffic at [::1]:443.
     * Web browsers should use URL https://cms.jobzone.local:443. Requests must have Host header of "cms.jobzone.local".
       Start DNS query for cms.jobzone.local.
    DNS query failed: No such host is known..
    Please review the host name cms.jobzone.local.
    Binding Diagnostics does not verify certificates and other SSL/TLS related settings.
    Please run SSL Diagnostics at server level to analyze SSL/TLS configuration. More information can be found at https://docs.jexusmanager.com/tutorials/ssl-diagnostics.html.
    
    
    

    When I select Edit Bindings in IIS I see that there appears to be no configured bindings. Not sure if that is correct.

    enter image description here

    Any pointers or help in resolving this would be greatly appreciated.

    Monday, November 9, 2020 9:13 PM

All replies

  • User-474980206 posted

    IIS is not listening on port 27251, but rather 443. also IIS is using host header cms.jobzone.local. so the correct start url is. 

      https://cms.jobzone.local

    note: this assumes cms.jobzone.local resolves to the local box you are running IIS and visual studio on.

    Monday, November 9, 2020 9:58 PM
  • User753101303 posted

    Hi,

    Check "Project"," Properties". "Web". I would the say the project url is left to what it was with IIS Express and needs to be change to what you have in IIS (plus maybe really chaning IIS Expres to IIS?)

    On my side I'm always using IIS Express.

    Monday, November 23, 2020 12:34 PM