locked
Why Does SQL Server No Longer Recognizes My Database? RRS feed

  • Question

  • I've installed three components to VS 2010: C#, VB, and SQL Server (Juneau). I haven't used C# yet, so that's irrelevant. I run Juneau from it's own icon/executable, and VB from it's own icon/executable. I created a database in my local Juneau server. I then created a desktop application intended to make data entry easier. However, when I tried to connect to the database, I found that I didn't have access to it. I went to the file itself in the Windows 7 File Manager and adjusted the security on the file (via the Windows 7 operating system itself) to give my Windows username access to the file. Now, I can reference the database in VB 2010, but when I pull up SQL Server/Juneau, the database is no longer a part of the local server. Obviously, the file still exists and is intact, but how can I get it to be part of the Juneau databases again?

     

    Thanks in advance for your help.


    Rob
    Saturday, August 13, 2011 6:55 PM

All replies

  • . Now, I can reference the database in VB 2010, but when I pull up SQL Server/Juneau, the database is no longer a part of the local server.


    Rob


    Hello Rob,

    By this I guess you create the database in Visual Studio and by default VS uses user instance of SQL Server, see also http://msdn.microsoft.com/en-us/library/ms254504.aspx.

    Copy the mdf + ldf files to the data folder of SQL Server and attach them as a database.


    Olaf Helper
    * cogito ergo sum * errare humanum est * quote erat demonstrandum *
    Wenn ich denke, ist das ein Fehler und das beweise ich täglich
    Blog Xing
    Sunday, August 14, 2011 5:27 AM
  • No, I created the database in MS SQL Server 2010 (Code name Juneau). Then I tried to reference it in VB 2010. It didn't work. I gave my Windows 7 login access to the file, and I could reference it in VB 2010, but now I can't reference it in MS SQL Server 2010.

     

    Incidentally, I tried making copies of the file, and I'm told by the operating system that I can't do that. This is perplexing.


    Rob
    Thursday, August 18, 2011 5:26 AM
  • Hi Rob,

    Have you tried stopping the SQL Server services prior performing any copy operation?

    Mu suggestion is first stop the services, so then you won't get Operating System leavel errors, than move the database to a different location (testing purpose) and then re-attach the database - see if that works.

    Thanks,-Danish.


    "the .net"
    Wednesday, August 24, 2011 7:01 AM
  • Just to get it right, there is no Juneau server. Juneau is the code name for SQL Server Development Studio.

    There is no SQL Server 2010, the ode name for the vnext of SQL Server is Denali.

    Juneau is the tool for designing / developing and deploying databases.

    .-Jens


    Jens K. Suessmeyer http://blogs.msdn.com/Jenss
    Wednesday, August 24, 2011 7:28 AM