locked
lastmod datetime invalid according to google RRS feed

  • Question

  • User836112793 posted

    When submitting a SEO Toolkit generated sitemap to google, I get a warning about the lastmod tag invalid date

    looking at the w3c specs:

          YYYY (eg 1997)
          YYYY-MM (eg 1997-07)
          YYYY-MM-DD (eg 1997-07-16)
          YYYY-MM-DDThh:mmTZD (eg 1997-07-16T19:20+01:00)
          YYYY-MM-DDThh:mm:ssTZD (eg 1997-07-16T19:20:30+01:00)
          YYYY-MM-DDThh:mm:ss.sTZD (eg 1997-07-16T19:20:30.45+01:00)
    these are the possible combo's

    SEO toolkit does: 2009-06-07T15:54:34 and is missing TZS=  time zone designator (Z or +hh:mm or -hh:mm)

    So pretty much a extra Z in the end would fix this.

    </lastmod>

    Sunday, June 7, 2009 12:56 PM

All replies

  • User1331732461 posted

    Thanks for letting use the issue. We logged this issue as a product bug and will check how to fix this issue for next product release.

    Wednesday, June 24, 2009 3:42 PM
  • User223665139 posted

    Is there any fix available for this bug?

    I downloaded the addin a few days ago - the bug still exists.

    Saturday, September 12, 2009 9:35 AM
  • User-47214744 posted

    We will be shipping Beta 2 in a few days that includes the fix for this.

    Tuesday, September 15, 2009 9:16 PM
  • User-47214744 posted

    Today we have released the Beta 2 version of the IIS SEO Toolkit that includes the fix for this.

    Just go to: http://www.iis.net/extensions/SEOToolkit 

    Thursday, September 24, 2009 2:06 PM