locked
Administrator Password Problem-cant figure it out RRS feed

  • Question

  • hello i recently installed Web platform installer and i found an application called nservice and i began to install it and it says it needs the database admin username and password i entered the administrator password along with the username sa (which was there already) and it comes back to me saying it could not authenticate "sa"  ihave tried my username and password  and the administrator account password but it still will not recongnize it if any one can help me that would be fantastic but for now my website is down
    Tuesday, October 19, 2010 12:09 AM

Answers

  • .\SQLEXPRESS looks fine as long as you are connecting from the same computer. The . means the local computer, and SQLEXPRESS is a named instance of SQL Server. Is your SQL Server in mixed mode security? That is, SQL Server installs with Windows Authentication. SQL Server Authentation is an option, that enables the sa account. (Mixed mode is running in both Windows and SQL Server Authentication which is what you want if you are going to use the sa account). And if you installed SQL Server as Windows, and then changed to Mixed, you need to enable the sa account. See How to: Change Server Authentication Mode http://msdn.microsoft.com/en-us/library/ms188670.aspx
    Rick Byham, Microsoft, SQL Server Books Online, Implies no warranty
    • Proposed as answer by Grace Liu Wednesday, October 20, 2010 4:12 AM
    • Marked as answer by Lief Fox Wednesday, October 20, 2010 10:09 AM
    Tuesday, October 19, 2010 9:00 PM

All replies

  • Please check error log and see if you get "login failed for user".

    First, I am trying to figure out whether it is reaching to proper SQL Server to authenticate or not.
    Balmukund Lakhani | Please mark solved if I've answered your question
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    --------------------------------------------------------------------------------
    My Blog: http://blogs.msdn.com/blakhani
    Team Blog: http://blogs.msdn.com/sqlserverfaq
    • Proposed as answer by Grace Liu Wednesday, October 20, 2010 4:12 AM
    Tuesday, October 19, 2010 2:00 AM
  • Please check error log and see if you get "login failed for user".

    First, I am trying to figure out whether it is reaching to proper SQL Server to authenticate or not.
    Balmukund Lakhani | Please mark solved if I've answered your question
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    --------------------------------------------------------------------------------
    My Blog: http://blogs.msdn.com/blakhani
    Team Blog: http://blogs.msdn.com/sqlserverfaq

    that is exactly what i get. the SQL server is on the local machine and in the setup for the application i am trying to install it shows the default SQL server as being ".\SQLEXPRESS" without quotes is it suppose tobe that way or should it be something else
    Tuesday, October 19, 2010 2:05 AM
  • .\SQLEXPRESS looks fine as long as you are connecting from the same computer. The . means the local computer, and SQLEXPRESS is a named instance of SQL Server. Is your SQL Server in mixed mode security? That is, SQL Server installs with Windows Authentication. SQL Server Authentation is an option, that enables the sa account. (Mixed mode is running in both Windows and SQL Server Authentication which is what you want if you are going to use the sa account). And if you installed SQL Server as Windows, and then changed to Mixed, you need to enable the sa account. See How to: Change Server Authentication Mode http://msdn.microsoft.com/en-us/library/ms188670.aspx
    Rick Byham, Microsoft, SQL Server Books Online, Implies no warranty
    • Proposed as answer by Grace Liu Wednesday, October 20, 2010 4:12 AM
    • Marked as answer by Lief Fox Wednesday, October 20, 2010 10:09 AM
    Tuesday, October 19, 2010 9:00 PM