none
HTML Select in task pane value not changing on mouse click RRS feed

  • Question

  • This is a task pane app in Word 2016 in Windows 10. I can change the value of the select by using the keyboard, but if I use the mouse it simply closes the drop down.

    If I open the page directly in IE and Edge, it works as expected.

    Thanks!

    Monday, February 27, 2017 8:03 PM

Answers

  • Hi Doug,

    Could you share us your code which could reproduce your issue?

    Based on your description, it seems you are developing Word AddIn?

    I made a test with below code, it works correctly on Word Desktop with mouse.

    <div id="content-main">
            <div class="padding">
                <br />
                <p class="ms-font-xxl ms-fontColor-neutralSecondary ms-fontWeight-semilight">Sample</p>
                <br /><br />
                <div class="ms-font-xl ms-fontColor-neutralTertiary">Select some text</div>
                <p class="ms-font-m-plus ms-fontColor-neutralTertiary" id="template-description"></p>
                <div class="ms-font-m"><a target="_blank" class="ms-Link ms-Link--hero" href="https://go.microsoft.com/fwlink/?LinkId=276812">Find more samples online...</a></div>
                <br /><br />
    
                <button class="ms-Button ms-Button--primary" id="highlight-button">
                    <span class="ms-Button-icon"><i class="ms-Icon ms-Icon--plus"></i></span>
                    <span class="ms-Button-label" id="button-text"></span>
                    <span class="ms-Button-description" id="button-desc"></span>
                </button>
                <select>
                    <option value="volvo">Volvo</option>
                    <option value="saab">Saab</option>
                    <option value="mercedes">Mercedes</option>
                    <option value="audi">Audi</option>
                </select> 
            </div>
        </div>
    

    Best Regards,

    Edward


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Doug WareMVP Wednesday, March 1, 2017 2:42 AM
    Tuesday, February 28, 2017 6:25 AM

All replies

  • Hi Doug,

    Could you share us your code which could reproduce your issue?

    Based on your description, it seems you are developing Word AddIn?

    I made a test with below code, it works correctly on Word Desktop with mouse.

    <div id="content-main">
            <div class="padding">
                <br />
                <p class="ms-font-xxl ms-fontColor-neutralSecondary ms-fontWeight-semilight">Sample</p>
                <br /><br />
                <div class="ms-font-xl ms-fontColor-neutralTertiary">Select some text</div>
                <p class="ms-font-m-plus ms-fontColor-neutralTertiary" id="template-description"></p>
                <div class="ms-font-m"><a target="_blank" class="ms-Link ms-Link--hero" href="https://go.microsoft.com/fwlink/?LinkId=276812">Find more samples online...</a></div>
                <br /><br />
    
                <button class="ms-Button ms-Button--primary" id="highlight-button">
                    <span class="ms-Button-icon"><i class="ms-Icon ms-Icon--plus"></i></span>
                    <span class="ms-Button-label" id="button-text"></span>
                    <span class="ms-Button-description" id="button-desc"></span>
                </button>
                <select>
                    <option value="volvo">Volvo</option>
                    <option value="saab">Saab</option>
                    <option value="mercedes">Mercedes</option>
                    <option value="audi">Audi</option>
                </select> 
            </div>
        </div>
    

    Best Regards,

    Edward


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Doug WareMVP Wednesday, March 1, 2017 2:42 AM
    Tuesday, February 28, 2017 6:25 AM
  • Hi Edward,

    It seems it was some sort of environmental issue. After a system restart everything worked as expected.

    Thanks!

    Wednesday, March 1, 2017 2:42 AM