none
EDI reporting RRS feed

  • Question

  • I am looking for a way to search BizTalk 2006 R2 for EDI files based on specific values in the EDI message.  For an 850 I would need to search by PO Number, for 810 I would need to search by invoice number.  I would also need to retrieve “Sent to Party”, “Sent Date”, “997 Status”

     

    I tried promoting the properties I needed but was unable to get the promoted properties to show up in HAT (I turned on all document tracking on ports, and on the actual schema in BT and the SQL agent is running) so I didn’t bother looking for them in the database.  I have seen 3rd party solutions that would work but I was hoping to find an “Out of the Box” solution.

     

    Any help would be appreciated.

     

    Thanks

    Tom

    Thursday, September 10, 2009 2:12 PM

Answers

All replies

  • Are you getting any error log? If yes then what was that?
    Thanks, Raja
    Friday, September 11, 2009 6:04 AM
  • Hi Tom,

    Do you have EDI/AS2 status reporting configured on your machine?
    I haven't really used it for EDI. Only for AS2.
    Just note that you need to configure BAM before you configure this.
    It will give you an extra option at the bottom of the group hub page.

    Kind Regards
    Tim
    Friday, September 11, 2009 1:47 PM
  • Did you enable tracking message bodies? Also, you should check to store the EDI message body in the EDI properties for the parties.

    An approach I think works better is to use pipeline components to log message details. Eric Stott has a good solution for this: http://blog.biztalk-info.com/archive/2008/06/18/R2_EDI_Reporting_what_is_lacking_and_what_I_did.aspx

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Friday, September 11, 2009 7:03 PM
    Moderator
  • I have the track bodies and properties set on the receive port and send port.  I enabled "activate EDI reporting" and "store transaction set/payload" on the party under EDI setting and the the store inbound AS2 message on the AS2 settings for the party.  But I am still unable to see any properties in HAT.  All the BizTalk SQL jobs are working without errors.  There are no errors in the event log. 

    Ben,

    I have looked at Eric Stott's EDI reporting solution and was hoping to just use BizTalk's functionality for my issue. 

    Thanks
    Monday, September 14, 2009 3:41 PM
  • still you couldn't see any message info inside HAT if yes then what is the receive pipeline you are using? If pass through then could you try with other pipeline.
    Thanks, Raja
    Sunday, October 4, 2009 5:23 PM
  • I am using the AS2EDIReceive pipeline.

    Thanks
    Tom
    • Marked as answer by ParahT Tuesday, October 13, 2009 9:09 PM
    Monday, October 5, 2009 4:39 PM