locked
MazeSimulator Manifest won't run RRS feed

  • General discussion

  • I keep getting the following error:

    **ERror Creating service.  Service type://www.promrds.com/contracts/2008/01/mazesimulator.html [05/18/2010 14:18:03]http://computername.server.com:50000/constructor]

    ***service creation failure most common reasons:

    -Service Contract identifier in manifest or Create request does not match Contract.identifier

    -Service references a different version of runtim assemblies

    Additional information can be found in the system debugger log.

     

    What should I do to get it to work? I am trying to do the tele-operation service, but get a similar error, and i thought it was because the mazesimulator wasn't running.  But I think that might have caused a problem, because you can only have one DSS node running at a time. So, now I am at a loss?

    Tuesday, May 18, 2010 7:38 PM

All replies

  • Did you compile the Maze Simulator? You should try running it on its own first. Teleoperation won't work if you try to run it before compiling the Maze Simulator.

    Trevor

     

    Thursday, May 20, 2010 11:33 AM
  • I get a similar error when I run the Maze Simulator first. I will try it again to make sure I am running it first, and then running Teleoperation.
    Thursday, May 20, 2010 2:23 PM
  • The Maze Simulator is just a manifest, right?  How do I run it?  I am in Chapter 4 of the MRDS.

    Wednesday, June 2, 2010 10:07 PM
  • You need to build the Maze Simulator service before you can run the manifest. It also depends on the Simulated Differential Drive. Teleoperation relies on the Maze Simulator.

    Have you build all of the samples? You can use the BuildAll.cmd script to do this. If you are working through the book and are only up to Chapter 4, then you need to skip ahead to Chapter 9 and build the projects there because that's where the Maze Simulator is.

    Trevor

     

    Thursday, June 3, 2010 6:13 AM
  • Good idea. I went to Chapter 9 and tried to run the .cmd files and the command window pops up and then closes...and then nothing. I must be missing a step.  Do i need to make any changes to the samples provided in Chapter 9, or just use them as is? Do i need to open up the .cmd files  another way? I am just clicking on them right now. Also, the buildall is doing something similar. I don't see anything really being built.  I put the ProMRDS folder in my MRDS R3 directory.

    I have downloaded the newest edition of ProMRDS. Released on June 1, 2010.
    Thursday, June 3, 2010 1:57 PM
  • I found out it was a few things combined that created my problem.  There is a process to the madness.  It starts with the install of R3, It also helps to have the Silverlight SDK 3.0 installed , and building all, then putting ProMRDS into the MRDS folder, and making sure it isn't ProMRDS/ProMRDS , just /ProMRDS.  Then doing the build all in ProMRDS, do it twice for fun (i am using VS2008). I can now run the teleoperation wihthout a problem.
    Thursday, June 3, 2010 7:13 PM
  • Glad you got it working :-)

    Thanks for the step-by-step instructions. I know that there are a lot of "moving parts".

    Trevor

     

    Sunday, June 6, 2010 12:25 AM