locked
BizTalk Batching Orchestration Error RRS feed

  • Question

  • Hi,

    I am getting below error while batching 277_CA acknowledgements..anyone has any idea about this error. 

    xlang/s engine event log entry: Uncaught exception (see the 'inner exception' below) has suspended an instance of service 'Microsoft.BizTalk.Edi.BatchingOrchestration.BatchingService(2a16c595-614b-9563-c13f-ebd20e4a6154)'.
    The service instance will remain suspended until administratively resumed or terminated. 
    If resumed the instance will continue from its last persisted state and may re-throw the same unexpected exception.
    InstanceId: 501e92fa-dcd1-4145-9cbf-c8a092b533ec
    Shape name: ThrowException
    ShapeId: 3fa755aa-82fe-4ad4-8fcd-6ccb0c724428
    Exception thrown from: segment 10, progress 7
    Inner exception: The property messageId's length [6] exceeded the maximum allowed length [5]

    Exception type: ArgumentException
    Source: Microsoft.BizTalk.Edi.BatchingOrchestration
    Target Site: Microsoft.XLANGs.Core.StopConditions segment10(Microsoft.XLANGs.Core.StopConditions)
    The following is a stack trace that identifies the location where the exception occured

       at Microsoft.BizTalk.Edi.BatchingOrchestration.BatchingService.segment10(StopConditions stopOn)
       at Microsoft.XLANGs.Core.SegmentScheduler.RunASegment(Segment s, StopConditions stopCond, Exception& exp)

                    
    Tuesday, November 24, 2015 3:11 PM

Answers

  • Apologies for updating the status so late….

    The main problem for this issue is there are two schemas with different namespace and root node.

    I was using custom schema for the batching and somehow the batch orchestration was NOT using this custom schema (Used custom namespace in party settings) hence getting the “Inner exception: The property messageId's length [6] exceeded the maximum allowed length [5]” error.

    • Marked as answer by Sriknath Wednesday, February 3, 2016 1:38 PM
    Wednesday, February 3, 2016 1:37 PM

All replies

  • Hi Sree,

    You are getting exception "Inner exception: The property messageId's length [6] exceeded the maximum allowed length [5]" .

    In your schema is there any field with name messageId ? Can you please validate the length of data passed into the messageId element.

    Thanks

    Abhishek


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply

    Wednesday, November 25, 2015 7:50 AM
  • Hi Abhishek,

    Thanks for the reply...I am getting this error while batching "277CA – Health Care Claim Acknowledgement" transaction. I have verified the context properties in suspended instance and there is no field with the name "MessageId" in the list. The error is in Microsoft.BizTalk.Edi.BatchingOrchestration.BatchingService orchestration in BizTalk.EDI.Application.

    Please let me know if you need any other info.

    Thanks,

    Sree.

    Wednesday, November 25, 2015 9:09 AM
  • Hi Sree,

    Welcome on MSDN forum.

    Could you please check the suspended error body and verify with schema. Seems segment10 should have MessageId and it throwing error 'The property messageId's length [6] exceeded the maximum allowed length [5]'.

    Please check and let us know the test result.


    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, November 26, 2015 7:51 PM
    Moderator
  • Could you check the below article, it talks about a similar issue-

    Max limit of acceptable Edifact interchange control number has reached for Guest settings

    Explanation

    This Error/Warning/Information event indicates that the send pipeline could not process the outgoing interchange because the interchange control number in the ISA13 field specified in the global settings, specifically the reference number in field UNB5.2, was greater than the maximum allowable value. The maximum allowable value for the interchange control number depends upon the values of the three fields in UNB5. The maximum number of characters is 14 for the reference number in field UNB5.2, 13 for the prefix in UNB5.1 and 13 for the suffix in UNB5.3, and 14 for all three fields combined.

    User Action

    To resolve this error, reset the reference number field (UNB5.2) of the interchange control number, as follows:

    1. In the EDI Global Properties dialog box, open the UNB Segment Definition page.

    2. Click the Edit field associated with the UNB5 field.

    3. Set the middle field of the interchange control number (the reference number in UNB5.2) to a new value such that the field has an acceptable number of digits.


    Thanks,
    Prashant

    My BizTalk Blog
    -------------------------------------------------------------------------
    Please mark this post accordingly if it answers your query or is helpful.

    Friday, November 27, 2015 7:08 AM
  • Can you open the Orchestration Debugger and see exactly which Shape it's stopping at?
    Sunday, November 29, 2015 3:19 PM
    Moderator
  • Apologies for updating the status so late….

    The main problem for this issue is there are two schemas with different namespace and root node.

    I was using custom schema for the batching and somehow the batch orchestration was NOT using this custom schema (Used custom namespace in party settings) hence getting the “Inner exception: The property messageId's length [6] exceeded the maximum allowed length [5]” error.

    • Marked as answer by Sriknath Wednesday, February 3, 2016 1:38 PM
    Wednesday, February 3, 2016 1:37 PM