none
Connection Problem to AzureDB RRS feed

  • Question

  • Hi,

    I established a SQL Database and tried to connect via Management Studio which worked somehow. A dialog popped up and I was asked to login to create an Firewall rule. This works, a firewall rule is created in azure, but after finishing the same popup window appears asking again that the ip is not reachable. so infinite process has started, I am not able to connect. 

    I don't know what I can do as it is obviously no connection problem as I am able to connect...

    I tried already different Wlan, different computer, made the exception rule from 0.0.0.0. to 255.255.255. etc., nothing worked.

    Any suggestions?

    Thank you very much.

    Bax

    P.S. I am not able to upload pics. Don't know why...

    Monday, July 29, 2019 10:42 AM

All replies

  • Hi,

    Please verify your IP to firewall.  Try giving IP range rather than your particular machine. 

    Sometimes, your company proxy IP might be different from your machine IP. 



    -Malleswar

    Monday, July 29, 2019 11:02 AM
  • Hi Malleswar

    thank you for your answer!

    as mentioned I tried all your proposals already...I was trying via my home network, company network and hotspot from my phone. I tried to open port 1433 in the local firewall, I tried it already on two different computers... and I gave the whole IP range open. 


    Any other suggestions? Maybe a setting on Azure Side?

    I tried to enter a link to the pics which is not possible either...how can i validate my account????


    Monday, July 29, 2019 12:24 PM
  • copy paste into browser...

    https://1drv.ms/u/s!ApUR_Ugj73ZhiXRCU7TS7bwCx1jr?e=9Jo75o
    (POP UP, which appears every time again, each time saving a rule on the server)

    https://1drv.ms/u/s!ApUR_Ugj73ZhiXPLo0dpnbPn7rJ6?e=H7RXq

    (as a proove, the server firewall)


    Monday, July 29, 2019 12:26 PM
  • Hi,

    Just to test this, Please allow all the IPs.

    enter image description here


    -Malleswar

    Monday, July 29, 2019 12:48 PM
  • Hi Malleswar

    thank you for your answer!

    I already tried this (see my first post!) and tried it again...obviously access is possible, as the rules are added...

    The popup says in one opening cycle that I am not logged in, the next says that I am logged in with my mail. 

    https://1drv.ms/u/s!ApUR_Ugj73ZhiXJ80xHPmVLxYjR7?e=BcyD25
    Have a look on the screen copies...

    Other suggestions?

    Best bax

    Monday, July 29, 2019 1:33 PM
  • Sorry, its my bad. Missed to see that.

    Please keep public access and share me the screenshot of whats happening after entering credentials in SSMS 


    -Malleswar

    Monday, July 29, 2019 1:53 PM
  • Hi Malleswar

    funny, I saw a video tutorial from you today...;-)

    I added 3 pics of what happened, please consider them in order 1,2,3 

    https://1drv.ms/u/s!ApUR_Ugj73ZhiXJ80xHPmVLxYjR7?e=BcyD25

    thank you very, very much!

    Monday, July 29, 2019 2:53 PM
  • Good day Bax,

    1. open VM in the Azure and try to connect to your server

    2. If you can get/have a laptop, then try to connect the Azure Virtual Server using the laptop from a different location, where other people can connect their service.

    This will confirm that the issue is probably with your local network configuration, which according to your description make sense.

    There are a lot of companies which monitor their network use and once the IT see strange use of port which they do not like, then they block it => the result is that people succeed to connect first time or several times and in one point they find that they are blocked

    Please inform us what the result (can you connect from VM, can you connect from different place where other people connect their servers)


    signature   Ronen Ariely
     [Personal Site]    [Blog]    [Facebook]    [Linkedin]


    Monday, July 29, 2019 9:08 PM
    Moderator
  • Can you check that your login does actually have access.

    In the Azure Portal, go to your SQL DB and click on the Query Editor. Try and login with the same credentials you have been trying with SSMS.

    If that does not work, then you can either try resetting the password (login with the admin account if you have access), other wise you should also check that your AD Account has access to the resource. Check this through the Access Control blade on the Azure SQL Server level of your SQL DB.


    Martin Cairney SQL Server MVP

    Monday, July 29, 2019 11:45 PM
  • Hi to all, 

    thank you for dealing with the problem! I am really desperate in the meantime! 

    @Ronan: I tried already several networks. Home, Work and Smartphone hotspot. As I am able to connect to the server via smartphone hotspot and the firewall exception is saved on the Server (connection is possible to establish), I don't think, that this is the problem. 
    But I made a virtual machine because and i am not able to establish a RDP to this...error message in the pic folder...I tried it via hot spot and company network. I opened port 1433, 3389 on my computer.  Don't know if I did it correctly as I was not able to reach the port via "canyouseeme"...

    @Martin: I tried to login into query editor and it was not possbile. I logged in with the old password. Error message in my picture folder. 

    Via Microsoft Account (out of Azure, as I was forced to do it outside) I refreshed my password. But, still not able to login into Query editor. But different error message, which is in the pic folder. 

    Thank you so far! Any other suggestions?

    https://1drv.ms/u/s!ApUR_Ugj73ZhiXJ80xHPmVLxYjR7?e=BcyD25

    Thank you from Switzerland

    Bax





    Tuesday, July 30, 2019 7:09 AM
  • Hi Bax,

    Thanks for the feedback. I believe this issue needs deeper investigation.

    So, for a deeper investigation and immediate assistance on this issue, if you have a support plan you may file a support ticket, else could you send an email to AzCommunity @ Microsoft dot com with the below details, we would like to work closer with you on this matter. 

    Thread URL:
    Subscription ID:

    Hope this helps.

    Wednesday, July 31, 2019 9:19 AM
    Moderator
  • Hi Bax,

    I hope your concern has been addressed with Azure support. It would be great if you could share the resolution as well. So that if anyone else is facing the same issue will be able to use the same resolution.

    Wednesday, August 14, 2019 9:17 AM
    Moderator
  • Hi angoyal-msft,

    the issue has been addressed to the support, someone contacted me and we are still ongoing...

    In case I'll find a solution I am going to post it here...

    Best 

    Bernd

    Wednesday, August 14, 2019 9:31 AM