none
error(1275):driver blocked from loading. RRS feed

  • Question

  • This error always comes out, when I try to run a  helloworld.sys file.

    pc: win7 x64 uitimate service pack 1

    tool:DriverMonitor (another tool has tried, but failed too.)

    Open DriverMonitor with rights of administrators. it seems right to open .sys files, but error(1275) comes when try to start drivers. I used several ways trying to  handle digital certificate,but it doesn't work.

    1. press F8 when os starts, choose Disable Driver Signature mandatory mode and enter. failed.

    2.bcdedit  /set testsigning on. restart win7 ,enter "test mode" ,failed.

    3. bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS. failed.

    4.  turnoff UAC.failed.

    I use vs2013+wdk to built .sys file, it seems vs20113 gives signature for test,  it shows normal of digital certificate of .sys file. I wander if there is other reason that lead to this.

    I will be truly thankful if there is any one who can give me an idea.

    Monday, September 22, 2014 7:38 AM

Answers

All replies

  • Which version of WDK are you using? Creating a new driver and loading shouldn't be a problem. The driver will be signed by VS during build. Did you try installing the driver using DevCon?
    • Edited by its_me_here Monday, September 22, 2014 2:07 PM
    Monday, September 22, 2014 10:28 AM
  • You should be able to do this with F8 if you have a debugger connected.  Unfortunately error 1275 ERROR_DRIVER_BLOCKED does not give a lot of indication of the problem.  The driver you have built is a Windows 7 x64 (i.e. AMD64) driver one hopes?


    Don Burn Windows Filesystem and Driver Consulting Website: http://www.windrvr.com

    Monday, September 22, 2014 2:54 PM
  • Use osrloader a gr8 tool to load and start the driver also you can put some dbgprint's in your 

    driver code so you can see the output on loading the driver in DbgView. Dbgview you can find at sysinternals.

    Please do make the changes  for DbgPrint in Dbgview shell:

    1. Open regedit 

    2.open hklm/ccs/control/sessionmgr

    3.create new key Debug Print Filter and set DWORD key name as DEFAULT and vaule 8.

    4.restart the system and see the output.

    5.will work on xp and higher os's.

    Tuesday, September 23, 2014 8:59 AM
  • Note: that OSRLoader only works for legacy (i.e. non-PNP, non-hardware) drivers.


    Don Burn Windows Filesystem and Driver Consulting Website: http://www.windrvr.com

    Tuesday, September 23, 2014 10:49 AM
  • the version of WDK is 8.1 (download and install just as what msdn said.)

    thanks my unkown friend, my problem is figured out.

    Sunday, September 28, 2014 1:47 AM
  • Don Burn, thanks  a  lot.

    I had solved this problem in the same evening. Busy days, I forgot about this. Today in the morning,I come back to see if anyone is here that trys to help me.What you said is to the point. When I checked the configuration of project, I found it was bult in x32 way. Changed  platform to x64 and rebuilt. Error(1275) was disappear. 

    Sunday, September 28, 2014 2:20 AM
  • DRahul, thanks for your idea. I have solved this  problem.
    Sunday, September 28, 2014 2:33 AM