locked
SSAS 2005 Filter Webpart Connect to Reportview Webaprt not able to configue connection RRS feed

  • Question

  • Hi,

    We have bulit a cube using SSAS and we have used SSRS to generate reports using SSRS.I was able to to deploy the report on my sharepoint site.As the report generated had few parameters which was fetched from cube.So one can select these parameter in reportviewer webpart itself.But my requirement is have a separate filter for parameters.So i added a SSAS 2005 filter and connnected to the cube and got the parameter values.Wen i try to connect this filter to my reportviewer webpart,i m facing issues:

    1. Initially, Encode selected value as set was checked in SSAS 2005 Filter webpart configuration,I was able to configure connection between my filter webpart and my Reportviewer.But While generating the report it gave an error  saying  "The filter value provided for parameter 'YEARYear' is not a valid value". Then i thought Reportviewer may not accept multiple values as parameter as SSAS filter fetches the values from Cube.

    2.So i unchecked Encode selected value as set in the configuration of SSAS webpart.But this time wen i tried to configure the connection between SSAS Filter and Reportviewer, Filtered parameter has been greyed out.I m not able to connect to the Reportviewer webpart itself.

    I tried out other filters like choice filter too but in vain,not able to connect the filter to my Reportviewer webpart.Filtered parameter option has been grayed out.

    Is there any workaround for the same so that i can connect filter to Reportviewer webpart.Any help would be appreciated.


    Thanks in advance,
    Raghav




    • Edited by Mike Walsh FIN Tuesday, November 24, 2009 2:55 PM NEVER write in your texts that something is urgent. Forums are not for urgent questions. If you are in a hurry ring MS Customer Support Services
    Tuesday, November 24, 2009 1:29 PM