none
Exchange 2010 Outlook Anywhere issues RRS feed

  • Question

  • I have an Exchange 2010 cas server that works fine with OWA internally and over the internet, and Outlook Anywhere works fine internally. When I try to access it outside the office though, the authentication prompt just keeps coming up for any user I try it on. I have used the connectivity analyzer, and it gives me what I've pasted below. I have disabled OA and uninstalled the RPC, rebooted and installed again and set it back up, with no luck. I've also tried both NTLM and Basic setups on the server side, and they both give the same error from outside the office. I also have checked my firewall settings, and everything is good. The only thing I can think of is that my reverse proxy is causing an issue. We have RHEL 5 with apache doing reverse proxy. Everything else works though, so I'm not sure why OA wouldn't?

    RPC Proxy can't be pinged.
     
    Additional Details
     
    An unexpected network-level exception was encountered. Exception details:
    Message: The remote server returned an error: (501) Not Implemented.
    Type: Microsoft.Exchange.Tools.ExRca.Extensions.MapiTransportException
    Stack trace:
       at Microsoft.Exchange.Tools.ExRca.Extensions.MapiRpcTestClient.PingProtocolProxy(String endpointIdentifier)
       at Microsoft.Exchange.Tools.ExRca.Tests.MapiPingProxyTest.PerformTestReally()
    Exception details:
    Message: The remote server returned an error: (501) Not Implemented.
    Type: System.Net.WebException
    Stack trace:
       at System.Net.HttpWebRequest.GetResponse()
       at RpcPingLib.RpcPing.PingProxy(String internalServerFqdn, String endpoint)
       at Microsoft.Exchange.Tools.ExRca.Extensions.MapiRpcTestClient.PingProtocolProxy(String endpointIdentifier)
    Elapsed Time: 198 ms.


    • Edited by Jon_M Monday, July 21, 2014 8:43 PM
    Monday, July 21, 2014 8:42 PM

All replies

  • Can you please try to open the outlook with "use HTTPS even on fast connection" option ticked?

    If it prompts for a user credentials and if it worked there is nothing to check. Check your firewall , port 80,443.

    That's it.

    Hope it helps. 


    MAS

    Monday, July 21, 2014 11:37 PM
  • I have tried that, and it's the same thing. It asks for credentials over and over again. I have triple checked the ports on the firewall now and both 80 and 443 are open to my dmz reverse proxy, and then again from the reverse proxy in the dmz to my cas server inside. And again, OWA works fine from outside the environment setup also in the reverse proxy.
    Tuesday, July 22, 2014 12:08 PM
  • Hi Jon,

    I have exactly the same issue and was wondering if you might have resolved this?

    Many thanks

    Matt

    Tuesday, July 29, 2014 7:59 AM
  • Hello

    501 is an internal server error.

    Please browse RPC virtual directory from outside, and see if you are getting a default response - Which should be a blank page.

    If you are not getting a blank page, then you need to troubleshoot that first - May be re-install RPC over HTTP.

    Let me know if you need any help


    AkashG || For any further queries, please mark an email to akash.g.88@outlook.com ||

    Friday, August 1, 2014 4:49 PM