none
Unable to Install Kinect SDK get wizard ended prematurely message RRS feed

  • Question

  • HI,

    I try to install the SDK and half way through it begins to rollback and returns the following:

    Microsoft Kinect for Windows SDK Beta Setup Wizard ended prematurely because of ab error etc ............

    Please can you help , I seem to have all prerequisites so not too sure what 's happening

     

    Thanks

     

    Jonathan

     

    Friday, July 1, 2011 9:23 PM

Answers

All replies

  • Hi Jonathan,

    If you could you post the error messages you are receiving, it would help diagnosing the problem

    Thanks,

     


    Rick
    Saturday, July 2, 2011 2:11 AM
  • HI,

     

    I don't receive an error message other than it rolls back the install and the following:

     

    "Microsoft Kinect for Windows SDK Beta Setup Wizard ended prematurely because of an error. Your system has not been modified. To install the program at a later time, run Setup Wizard again. Click the Finish button to exit the Setup Wizard."


    If there's any command line prompt or any other way i can enable enable error messaging I will supply you with the output but other than that I get nothing returned.


    Regards


    Jonathan

    Saturday, July 2, 2011 7:03 AM
  • You can use the command line <package>.msi /help that will show you the options to use when using command line install mode.
    This way you can set a log file that might collect the messages during installation.

    Cheers.


    System Architect
    Saturday, July 2, 2011 2:41 PM
  • HI,

     

    I've now created a log file from the install and out of the 100k file the following text seems the most obvious problem.

     

    DIFXAPP: INFO:   ENTER:  DriverPackageInstallW

    DIFXAPP: WARNING:DRIVER_PACKAGE_LEGACY_MODE flag set but not supported on Plug and Play driver on VISTA. Flag will be ignored.

    DIFXAPP: ERROR:  One or more files referenced by 'C:\Program Files\Microsoft Research KinectSDK\Drivers\Device\kinectdevice.inf' cannot be found in the package.

    DIFXAPP: INFO:   RETURN: DriverPackageInstallW  (0xE0000303)

    DIFXAPP: ERROR: encountered while installing driver package 'C:\Program Files\Microsoft Research KinectSDK\Drivers\Device\kinectdevice.inf'

    DIFXAPP: ERROR: InstallDriverPackages failed with error 0xE0000303

    DIFXAPP: RETURN: InstallDriverPackages() 3758097155 (0xE0000303)

    CustomAction MsiInstallDrivers returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

    Action ended 16:37:04: InstallFinalize. Return value 3.

    Action 16:37:04: Rollback. Rolling back action:

     

    Any ideas what this is , one question, do i have to have the Kinect installed prior to installation ? if so where do i get the drivers or are they part of Win 7 or Studio 2010 or .net 4

     

    Many Thanks

     

    Jonathan

    Saturday, July 2, 2011 3:44 PM
  • Kinect drivers are part of the SDK, so no kinect related stuff is needed. Which SO are you running?
    Saturday, July 2, 2011 9:01 PM
  • I'm running windows 7 Enterprise

     

    Jonathan

    Saturday, July 2, 2011 9:41 PM
  • Have you tried to install the same package in another machine? If it works we can conclude that there is something impacting the installer in your machine. Maybe configuration, hardware or a installed package.

    Regards


    System Architect
    Saturday, July 2, 2011 9:46 PM
  • We have the same problem here. No error messsages, just fails. Windows 7 enterprise.

    Thanks


    Crile Carvey
    Sunday, July 3, 2011 11:46 PM
  • do you have all the requirements installed? Can you run with the command line option and get an error log like above?
    Monday, July 4, 2011 12:32 AM
  • An issue with Windows 7 Enterprise? I have Windows 7 Ultimate and it installs fine.

     


    System Architect
    Monday, July 4, 2011 1:51 AM
  • Sometimes people have had problems when old MSI installer is in system. This is typically fixed by installing Visual Studio 2010 Express (http://www.microsoft.com/express/Downloads/#2010-Visual-CPP). Another install problem that we saw in the past was that the installer launched a user account control popup, and it stops waiting for user response, then if user left UAC popup unattended for a while then installation rolls back, but this last one should have been fixed already.

    Do either of these seem related to your problem?

    Eddy


    I'm here to help
    Thursday, July 7, 2011 5:41 PM
  • I'm having the same problem on Windows 7 Enterprise. I've already installed Visual Studio 2010 Express. There was no pop-up that I saw. In fact, the install didn't get very far before I received the same message.

    Has anyone had any luck getting it installed on Windows 7 Enterprise?

    I'm trying to install the 64 bit version.
    Friday, July 8, 2011 3:56 PM
  • I just installed Silverlight, then tried to install the Kinect SDK and this time I didn't get the message. (Didn't Silverlight install with VS 2010 Express?) Hopefully the Kinect SDK actually installed this time....
    Friday, July 8, 2011 4:14 PM
  • Thanks, Carey, we are investigating. For other people running into this problem, does installing Silverlight fix it? Our SDK does not depend on Silverlight API, but Silverlight installation is probably updating some installation-related binaries that could provide a workaround for people running into this problem until we figure out what the real problem is.

    Thanks,
    Eddy


    I'm here to help
    Tuesday, July 12, 2011 3:25 AM
  • Installing SL does not fix it. Log says :

    ...

    Action ended 16:41:24: ExecuteAction. Return value 3.
    Action 16:41:24: FatalError.
    Action start 16:41:24: FatalError.
    Action 16:41:24: FatalError. Dialog created
    Action ended 16:41:25: FatalError. Return value 2.
    Action ended 16:41:25: INSTALL. Return value 3.

    ...

    Crile


    Crile Carvey
    Wednesday, July 13, 2011 10:47 PM
  • Ideas?
    Crile Carvey
    Thursday, July 14, 2011 3:19 PM
  • have you installed all updates and SP1 on the Enterprise machines?

    Thursday, July 14, 2011 10:21 PM
  • Thanks - yes, all updates are current.

    Crile


    Crile Carvey
    Friday, July 15, 2011 12:42 AM
  • Maybe you could try to use Procdump or Filemon tools to trace the execution of installer. I know this is a radical option but is a way to try see what is making the installer to fail the install operation..

    Cheers.


    System Architect
    Friday, July 15, 2011 2:43 AM
  • Thanks - I ran procmon while installing and I don;t see anything much that I understand. There are a bunch of BUFFER OVERFLOW events when msiexec.exe is trying to query HKLM\SOFTWARE\MICROSOFT\SystemCertificates\TrustedPublisher\Certificates\197A4AEBDB25F0170079BB8C73CB2D655E0018A4\Blob

    Does that ring any bells?

     

    Crile


    Crile Carvey
    Friday, July 15, 2011 3:18 PM
  • can you run msiexec /? and get the version number?
    Friday, July 15, 2011 7:34 PM
  • msiexec /? says:

    Windows ® Installer. V 5.0.7601.17514

    Thanks


    Crile Carvey
    Monday, July 18, 2011 5:39 PM
  • Try to delete all temp files before start install.

    To do that, go to Start > Run

    and type %TEMP% or %TMP%

    then delete all files or directories that Windows will display.

    After that, start the installation and see if it works.


    System Architect
    Monday, July 18, 2011 8:21 PM
  • Hello,

    I'm running into the same problem. Can't get the Kinect SDK to install.

     

    Running windows 7 enterprise x64. windows installer: 5.0.7601.17514

    I already tried all the above..

    The log from the installer states:

    Action 13:10:14: MsiProcessDrivers.
    Action start 13:10:14: MsiProcessDrivers.
    CustomAction MsiProcessDrivers returned actual error code 1157 (note this may not be 100% accurate if translation happened inside sandbox)
    Error 1723. There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor.  Action MsiProcessDrivers, entry: ProcessDriverPackages, library: C:\Windows\Installer\MSIE38D.tmp
    MSI (s) (10:4C) [13:10:16:411]: Product: Microsoft Kinect for Windows SDK Beta -- Error 1723. There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor.  Action MsiProcessDrivers, entry: ProcessDriverPackages, library: C:\Windows\Installer\MSIE38D.tmp

    Action ended 13:10:16: MsiProcessDrivers. Return value 3.
    Action ended 13:10:16: INSTALL. Return value 3.

     

    ran through procmon that gave me:

    - few buffer overflows on some international language things

    - pretty much for all CreateFiles actions that targeted "user" and "program files" folder the result: path not found

    - an access denied on MSI19ea.tmp (whatever that is for)

    - for a whole lot of CreateFiles that targeted the system32 folder the result "name not found" (e.g. windows\system32\ar-SA\scs.dll.mui..and a lot of other files named similar)

    - and I saw one buffer too small result on something

     

    Really hope that there's gonna be some sort of solution.

     

    Thanks and regards

    Peter

     

    Tuesday, July 19, 2011 12:20 PM
  • I checked my Windows directory and I dont have the scs.dll.mui file.

    Generally speaking, error 1157 means your system is misconfigured or its essential files are missing. Sorry to say but have you updated your OS properly?

    When you see a "path no found" message is good to try check the next lines to see if the process could resolve the issue using different paths.

    In general, procmon will show a critical error couple lines before the end of process.

    Take a look the link below and see if it can fix the issue

    http://support.microsoft.com/kb/301671

    Cheers


    System Architect
    Tuesday, July 19, 2011 2:09 PM
  • not sure if this has been asked or not.... are you a local admin on the box?
    Tuesday, July 19, 2011 8:33 PM
  • There are at least two of us here with issues - so I am not sure who is being asked :)... but yes, I am local admin. And the install fails just the same after deleting all temp files.

    I am very happy to hear any and all ideas. BTW, how many successful installs have you guys seen? Are we outliers?

    Crile


    Crile Carvey
    Wednesday, July 20, 2011 8:23 PM
  • we've had over 50k downloads, not sure how many installed on Enterprise. All of our dev machines here at MS are running Enterprise... Still looking for troubleshooting steps.
    Wednesday, July 20, 2011 9:05 PM
  • for the Enterprise users that are having issues, I have a fresh enterprise machine to try and repro with. What flavor of Visual Studio did you guys install?
    Wednesday, July 20, 2011 10:16 PM
  • Hey Crile,

    sorry for maybe messing up the conversation - but the more hints, the faster we can find a solution?!

    My system layout:

     

    Microsoft Visual Studio 2010 Ultimate V 10.0.30319.1 RTMRel. german edition

    .Net 4.0 V4.0.30319

    Windows 7 Enterprise 64Bit-Version (6.1, Build 7601) german edition SP1

    and yeah, I too am local admin, ProcMon: all Path not found messages were not corrected (at least as far as I could tell..), in the end of procmon there were only shutdown and deregistering messages (nothing hinting at an error).

    The provided link by carlao didn't really help me out - seemed to be targeting an error on win 98 machines?

    Is there a way of installing the SDK more directly (like driver files and libraries zipped?)

     

    Thanks and regards

    Peter.

    Thursday, July 21, 2011 6:43 AM
  • Todd, as to fresh install tests: I have this VS state according to Help / About:

    Version 10.0.40219.1 SP1Rel
    Microsoft .NET Framework
    Version 4.0.30319 SP1Rel

    Installed Version: Premium

    Microsoft Office Developer Tools   01021-532-2002102-70379
    Microsoft Office Developer Tools

    Microsoft Visual Basic 2010   01021-532-2002102-70379
    Microsoft Visual Basic 2010

    Microsoft Visual C# 2010   01021-532-2002102-70379
    Microsoft Visual C# 2010

    Microsoft Visual C++ 2010   01021-532-2002102-70379
    Microsoft Visual C++ 2010

    Microsoft Visual F# 2010   01021-532-2002102-70379
    Microsoft Visual F# 2010

    Microsoft Visual Studio 2010 Code Analysis Spell Checker   01021-532-2002102-70379
    Microsoft Visual Studio 2010 Code Analysis Spell Checker

    Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

    The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

    Microsoft Visual Studio 2010 Team Explorer   01021-532-2002102-70379
    Microsoft Visual Studio 2010 Team Explorer

    Microsoft Visual Web Developer 2010   01021-532-2002102-70379
    Microsoft Visual Web Developer 2010

    Microsoft Windows Phone Developer Tools - ENU   01021-532-2002102-70379
    Microsoft Windows Phone Developer Tools - ENU

    AnkhSVN - Subversion Support for Visual Studio   2.1.10129.17
    AnkhSVN - Subversion Support for Visual Studio 2.1.10129.17
     * Ankh.Package 2.1.10129.17
     * Subversion 1.6.16 via SharpSvn 1.6016.1637.10768

    SharpSvn is linked to: Apr 1.4.2, Apr-util 1.3.10, Neon 0.29.5, OpenSSL 1.0.0d 8 Feb 2011, serf 0.7.1, SQLite 3.7.5, Subversion 1.6.16-SharpSvn-tag-1.6.16@1076827, ZLib 1.2.5
    SharpSvn is dynamically linked to: Cyrus Sasl 2.1.23
    SharpSvn is optionally linked to: Berkeley DB 4.4.20, SharpPlink 1.6016.1637.10768

    Crystal Reports Templates for Microsoft Visual Studio 2010  
    Crystal Reports Templates for Microsoft Visual Studio 2010

    Microsoft Visual Studio 2010 Premium - ENU Service Pack 1 (KB983509)   KB983509
    This service pack is for Microsoft Visual Studio 2010 Premium - ENU.
    If you later install a more recent service pack, this service pack will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/983509.

    Microsoft

    Microsoft XNA Game Studio   4.0
    Microsoft XNA Game Studio 4.0
    Build 4.0.20823.0

    NuGet Package Manager   1.4.20615.9020
    NuGet Package Manager in Visual Studio. For more information about NuGet, visit
    http://docs.nuget.org/.

    protobuf-net

    Windows Azure Tools   Version 1.3
    Windows Azure Tools for Microsoft Visual Studio 2010 v1.3.31122.1601

    Thanks, Crile


    Crile Carvey
    Thursday, July 21, 2011 1:39 PM
  • Crile, is your Enterprise version the English US version?
    Thursday, July 21, 2011 5:56 PM
  • Yes, English US. By the way, we have another box here that is running the same OS but everything installed just fine...
    Crile Carvey
    Friday, July 22, 2011 3:41 PM
  • hmmm, what are/were the differences between the machines?
    Friday, July 22, 2011 6:10 PM
  • Maybe you can run procmon on both machines and compare the results.

    Cheers.


    System Architect
    Friday, July 22, 2011 6:45 PM
  • Todd, carlao,

    Sounds logical to diff the working and the nonworking. Can you suggest some tools we could use to compare the two systems? carlao mentions procmon - but I am not familiar with using it in this way.

    Crile

     


    Crile Carvey
    Friday, July 22, 2011 9:43 PM
  • Hi there,

    well, someone from the MS Support Germany I contacted compared my .msi-logs with running ones. He said that my installer failed at the point where it tries to install the usb-drivers for the kinect. Could that be a hint for a workaround?

     

    Regards,

    Peter

    Tuesday, July 26, 2011 6:26 AM
  • Peter suggests it may be a problem installing the USB driver, but I don't know how to fix it if it is... I would still really like to get the SDK installed on W7 64 bit and so far no luck after a month of trial and error. I can't be the only one, can I? More ideas welcomed.

    Crile


    Crile Carvey
    Thursday, July 28, 2011 6:56 PM
  • Hey Crile,

     

    since I couldn't get any further advice from MS Support I did it now the dirty way - but at least I got running what I need:

    - you probably won't be able to use audio

    - skeletal tracking works

    - uniniatilize doesn't seem to proberly turn off camera (IR Sensor stays on..) (also provided samples don't shut it down properly)

     

    Short and dirty Versoin:

    - installed Kinect SDK on another computer with W7 x64

    - copied Program Files (x86)\Microsoft Kinect SDK\ to disc and on the computer with the problem paste to the same directory

    then:

    - probably plug in Kinect sensor and when trying to install unknown hardware point to the copied directory (contains drivers)

    - I did not have this situation, because I already had the PrimeSense drivers installed - so I just replaced these drivers

    --> ugly, since now I only have:(Microsoft Kinect Audio Control, Kinect Camera, Kinect Device) - missing is the Kinect Audio Array Control. But doesn't matter to me since I want to evaluate skeletal tracking.

    Now you can basically run samples like skeletal viewer.

    To start programming:

    follow: http://channel9.msdn.com/Series/KinectSDKQuickstarts/Getting-Started

    - when adding reference: you won't find it in .NET - search it in file path and add Microsoft.Research.Kinect.dll

    - copy all *.dll from Program Files (x86)\Microsoft Kinect SDK\ to your %projectpath%\bin\debug\ dir (otherwise it won't find references from INuiInstanceHelper.dll and give you a XamlParseError (Nested Exception is File or Reference not found INuiInstanceHelper.dll)

     

    That's how I got it working. I can access the camera and get the skeletal tracking data that way.

     

    To clean up: (but not everything worked for me)

    ==================================

    Register dll in global assembly cache (probably mandatory in previous process?!)

    ------------------------------------------

    goto start -> all programs -> Visual Studio 2010 -> Tools -> Visual Studio Command Prompt (run as admin)

    - execute: gacutil.exe /i c:\program files (x86)\Microsoft Kinect SDK\Microsoft.Research.Kinect.dll

    - execute: gacutil.exe /i c:\program files (x86)\Microsoft Kinect SDK\INuiInstanceHelper.dll

    VS 2010 should not be running I guess.

    check that it is registered:

    - gacutil /l Microsoft.Research.Kinect

     

    Make the library show up in Visual Studio ".NET" tab when adding references:

    -------------------------------------------------------------------------------------

    http://support.microsoft.com/kb/306149/en-us?fr=1

    (did not work for me..)

     

    Right now - you still have to copy all *.dll (except Microsoft.Research.Kinect.dll and INuiInstanceHelper.dll) to the bin dir. Probably this could be solved by registering the other *.dll.

    - regsrv32 /i [for_all_the_other_dll]

    - add C:\program files (x86)\Microsoft Kinect SDK to your "path" environment variable

     

    -> now you can compile and run without having to copy any dll to the bin\debug directory - but I'm getting some asynchronous thread abort errors when exiting a minimal application (just nui.initialize and uninitialize in a wpf project)

    so I stuck to copying all the stuff.

     

    well that's it. wouldn't recommend it to anyone, but until there's a fix for the problem - at least I can evaluate the SDK now.

     

    Still hoping for a proper fix,

     

    Peter

    Monday, August 1, 2011 11:46 AM
  • Peter,

    Well done. At least this will help other guys with the same problem.

    Regarding to unable to turn off IR, this is a known issue already reported in other threads.

    Cheers.


    System Architect
    Monday, August 1, 2011 12:04 PM
  • did you try uninstalling the PrimSense drivers before installing the SDK? There are known issues with having those installed. Might have saved you a lot of work.
    Monday, August 1, 2011 7:16 PM
  • Hi Todd,

    yes, I did uninstall the PrimeSense drivers. But I only used the Win7 remove software feature. Apparently PrimeSense or Windows saves those drivers as backup somewhere (I had some issues with some other hardware before and that went far beyond removing a few .inf files..).

     

    I'm going to try to find a way to remove them permanently..but now having MS drivers and primesense once hidden somewhere in the system might prove to be difficult..we'll see. If anyone knows the .inf and (do i need those .pnf files?) and locations I'll be glad to try it out and remove them.

     

    As I said - i'd still like to install the proper way with the installer. And since others are facing the same problem on enterprise x64 machines..well - I'll be able to tell more at the end of the week I hope.

     

    oh - thanks carlao - I was already worried with the IR..that's at least one thing PrimeSense drivers did correctly. But having had a glimpse at the skeletal tracking of MS - really robust and worth for me working with them.

     

    Peter

    Tuesday, August 2, 2011 7:41 AM
  • Hi Peter,

    Control Panel > System > Device Manager. For Microsoft, you will find a node named Microsoft Kinect. For Prime Sense you will find a PrimeSense node name.

    What is important here is go to subnode, right-click the subnode name and chose Uninstall option. Repeat the same operation to Audio Array, Camera and Kinect Device.

    Check to see if you have any other Kinect driver installed and remove it using the process above. A reboot here seems to be a good idea.

    Note that you need have the Kinect connected to see the node names in Device Manager.

    Cheers.


    System Architect
    Tuesday, August 2, 2011 12:17 PM
  • I have windows 7 professional. I do admit that sometimes restarting the computer has helped with driver installs on any machine I have done driver installs on. I work at an IT department at a school and know that sometimes this can be frustrating. I have reproduced this scenario already with many different device drivers and versions of windows 7. First uninstall and restart computer. Then reinstall kinect sdk. Try making sure no other programs are using msi (BTW, in task manager its listed as msiexec). Having msiexec running other install programs still as a background service or process can cause malfunction of the installation. Also, some device drivers work best not  in a virtual pc too and malfunction if put in one.


    Wednesday, August 3, 2011 6:48 PM



  • Trying to click skip getting drivers from windows update after reinstalling the kinect sdk as i found this can cause problems by installing the open ni drivers from microsofts site or the open ni site for some reason. ALso, it cause the windows driver installer to look on local hard drive for the kinect drivers
    • Edited by The Thinker Thursday, October 27, 2011 2:14 PM
    Thursday, October 27, 2011 2:13 PM
  • I'm experiencing the similar error.

    I cant find any MSI logs; however the Event Viewer has the following:

    Faulting application name: MsiExec.exe, version: 5.0.7600.16385, time stamp: 0x4a5bc7bd
    Faulting module name: SETUPAPI.dll, version: 6.1.7600.16385, time stamp: 0x4a5be052
    Exception code: 0xc0000409
    Fault offset: 0x00000000000b7a42
    Faulting process id: 0x126c
    Faulting application start time: 0x01cc9c2a61a66e0a
    Faulting application path: C:\Windows\system32\MsiExec.exe
    Faulting module path: C:\Windows\system32\SETUPAPI.dll
    Report Id: a192be9d-081d-11e1-8c8f-f9b5f3011a7e

    and

    Fault bucket , type 0
    Event Name: BEX64
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: MsiExec.exe
    P2: 5.0.7600.16385
    P3: 4a5bc7bd
    P4: SETUPAPI.dll
    P5: 6.1.7600.16385
    P6: 4a5be052
    P7: 00000000000b7a42
    P8: c0000409
    P9: 0000000000000000
    P10:

    Attached files:
    C:\Windows\Temp\WER6E01.tmp.appcompat.txt
    C:\Windows\Temp\WER6E7F.tmp.WERInternalMetadata.xml
    C:\Windows\Temp\WER6E8F.tmp.hdmp
    C:\Windows\Temp\WER71CB.tmp.mdmp

    These files may be available here:
    C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_MsiExec.exe_a27b9468fe55fe5df9eafbf91190f2fed632da_cab_16457226

    Analysis symbol:
    Rechecking for solution: 0
    Report Id: a192be9d-081d-11e1-8c8f-f9b5f3011a7e
    Report Status: 4


    Windows 7 x64 Ultimate, VS2010 Standard.

    Sunday, November 6, 2011 2:28 AM
  • are you installing Beta 2? Do you have any previous SDK or other Kinect drivers installed?
    Sunday, November 6, 2011 3:40 AM
  • Yes, Beta2 SDK. The machine is otherwise clean; the Kinect is not yet even unpacked - sitting in the box :)
    Sunday, November 6, 2011 3:59 AM
  • Upd: tried on another PC, installed just fine. Strange :/

    It would be better, of course, if it installed correctly on mine, too :)

    Sunday, November 6, 2011 4:05 AM
  • the msiexec.exe on my machine is Windows ® Installer. V 5.0.7601.17514. What version is on the machine that installed successfully?
    Sunday, November 6, 2011 8:18 PM
  • My solution for problems with Kinect SDK unable to install:

    1. Use 64-bit version of SDK for 64-bit OS, even if you want to develop 32-bit app. 32-bit SDK fails to install due to incorrect DIFX used (see msi log file) and says only - "wizard has ended prematurely". Maybe developers will add a check for installers, to say "Use 64-bit installer version for this OS"?

    2. Another problem - .NET 4.0 Client Profile must be installed to install any version of SDK (Beta 1 - Beta 2 - 32 - 64), otherwise "wizard has ended prematurely" will be displayed. Maybe developers will add a check for installers, to say "Install .NET 4.0 Client Profile first", too?

    P.S.: Sorry for offtopic, but when HeadOverHeals and Mirroring settings will be added to this SDK. It will be very usefull, to place kinect under the roof or backward the tracked man.

    P.P.S: And maybe you can build SDK without shared DLLs from VC10 (Project settings -> c/c++ -> code generation -> Runtime library -> Select Multithreaded, not Multithreaded DLL)?

    P.P.P.S: And maybe you can fix incompatibility of SDK with VC older VC2010 just by changing:

     

     

    static_assert(E_NUI_FRAME_NO_DATA == 0x83010001, "Error code has changed.");

     

    to

     

    #if _MSC_VER >= 1600
    static_assert(E_NUI_FRAME_NO_DATA == 0x83010001, "Error code has changed.");
    #endif
    in MSR_NuiApi.h file?

    P.P.P.P.S: And maybe you can add possibility to get really unique id for kinect device, not the device path - as it changes on reinserting kinect to another usb port - serial number maybe - earlyer kinect hacks was able to do it, so kinect hw has serial number in eeprom or smth, sure.

    Tuesday, November 8, 2011 8:38 AM
  • My solution for problems with Kinect SDK unable to install:

    1. Use 64-bit version of SDK for 64-bit OS, even if you want to develop 32-bit app. 32-bit SDK fails to install due to incorrect DIFX used (see msi log file) and says only - "wizard has ended prematurely". Maybe developers will add a check for installers, to say "Use 64-bit installer version for this OS"?

    Ok, so, if this is true, has anyone found a way to use RDS4 beta with the Kinect SDK on a 64-bit machine? For some reason the build all in RDS does not find the Kinect SDK 64-bit version when I have it installed, and I get the end prematurely error when trying to install the 32 bit sdk.
    Monday, November 14, 2011 8:10 AM
  • Hi there all,

     

    cbarrett, thanks for the solutions.

    32 bit sdk gave the same problem.

    Downloaded 64k version worked a charm, no reboot necessary.

     

    Cheers

    Prem

    Monday, November 14, 2011 11:40 AM
  • i m trying to install SDK but every time getting an error that "error to writing file:microsoft.research.kinect.dll.verify that you have access to that directory" after that i click on retry then got an error of "the installer encountered an unexpected error installing this package.This may indicate a problem with this package.Error code is 2350" please help me out :(:(
    Sunday, November 27, 2011 3:26 PM
  • are you an admin on the machine?
    Sunday, December 4, 2011 9:12 PM
  • You have to be in administrators group to be an administrator. To double check this right click my computer->manage and under local users and groups. Then double click administrators group and if the username you use to logon is their then you are an admin.

    If at a workplace and under powerusers group you are not an admin because driver installs require you to be in administrators group not powerusers. I cant install drivers unless im an admin.


    Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. - "Sherlock holmes" "speak softly and carry a big stick" - theodore roosevelt. Fear leads to anger, anger leads to hate, hate leads to suffering - Yoda

    • Edited by The Thinker Tuesday, December 6, 2011 1:15 PM
    Tuesday, December 6, 2011 1:14 PM
  • I've been getting this error as well. Here are my error messages:

    === Logging started: 4/15/2012  19:18:50 ===
    The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2908. The arguments are: {B1FADDD1-0664-4C47-AE03-0B3E01878777}, , 

    The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2908. The arguments are: {32CD7C5B-BD3D-4590-8307-3391A080A43D}, , 

    Error 1935. An error occurred during the installation of assembly 'Microsoft.Research.Kinect,version="1.0.0.45",culture="neutral",publicKeyToken="31BF3856AD364E35",processorArchitecture="MSIL"'. Please refer to Help and Support for more information. HRESULT: 0x8002802F. assembly interface: , function: CreateAssemblyCache, component: {32CD7C5B-BD3D-4590-8307-3391A080A43D}
    === Logging stopped: 4/15/2012  19:19:26 ===

    Sunday, April 15, 2012 11:24 PM
  • this is with the Beta, have you tried the 1.0 SDK?
    Tuesday, April 17, 2012 7:36 PM