none
Program gets stuck / hangs at call to new Word.Application(); RRS feed

  • Question

  • Hi,

       I have a simple console application (built into an EXE using Visual studio 2013) which works fine in all Windows hosts except one. The one where it does not work is a Windows 2012 server with MS Office 2013 installed. I have the 2010 Interop assemblies installed on the 2012 server as well.

    I see that the program control gets stuck at:

    Word.Application myApp = new Word.Application(); I do  not get any errors / have no clue to figure out what is going wrong. I am running the exe as an Admin user.

    I think the issue is with the environment on the Windows 2012 server, but not sure what it might be.

    Please suggest.

    BR,

    Dip




    • Edited by Diip2 Tuesday, May 3, 2016 2:38 PM
    Tuesday, May 3, 2016 2:37 PM

Answers

  • Hi Dip,

    >>The one where it does not work is a Windows 2012 server with MS Office 2013 installed. I have the 2010 Interop assemblies installed on the 2012 server as well.

    There is no need to install the additional Office PIAs since it would be installed when we install the Office product. 

    >>Word.Application myApp = new Word.Application(); I do  not get any errors / have no clue to figure out what is going wrong. I am running the exe as an Admin user.

    Did you mean that the code execute successfully but there is no Word instance was created after the code was executed?

    Based on my understanding, it seems that the environment was broken, please try to repair/update the Office to see whether it is helpful.

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, May 4, 2016 1:55 AM
    Moderator