none
RDLC ReportViewer ResettingPageNumber OverallPageNumber RRS feed

  • Question

  • Hi All,

    i've a big issue using ReportViewer 2010 deployed with VS2010.

    long time ago i've seen new interesting features into SQLServer Reporting services 2008 R2: ResettingPageNumber on group; here is a good link to understand this feature:

    http://blogs.msdn.com/b/robertbruckner/archive/2010/04/25/report-design-reset-page-number-on-group.aspx

    I've tried to use this new features using Visual Studio 2010 and RDLC for ReportViewer 2010

    I'm surprised to know that ResettingPageNumber, Globals!OverallPageNumber and Globals!OverallTotalPages are not supported in rdlc file format and ReportViewer 2010; unfortunately, it seems this features is not included also in ReportViewer 2012.

    I don't understand why this excellect and simlpe feature (ResettingPageNumber) is not available for windows and asp.net application!

    We have many cases in which this feature could be the right solution of rendering correct report info to the user.

    Here is an example: report consisting of many invoices on different customers. Currently we are not able to show on invoice header "this is invoce page x of y total pages"; we are able to expose this info only when we do one anvoice at a time using Globals!PageNumber Globals!TotalPages.

    This is a big restriction.

    May we hope this features will be included on the Visual Studio 2012 and ReportViewer 2012 release?

    Thanks


    FabioBo

    Thursday, June 14, 2012 6:43 AM

All replies

  • Hi FabioBo,

    The feature was not available for the release of VS 2010. We are looking at VS 2012 and there may have be a bug associated with this functionality not being there. We are looking at it now and hopefully can make the release.


    Brad Syputa, Microsoft Reporting Services This posting is provided "AS IS" with no warranties.

    Tuesday, June 19, 2012 12:28 AM
  • We've checked this on the latest Dev11 RC release and the features that you mention are there, can you provide a little more information on your configuration. Are you opening a VS 2010 report (2008 RDL schema) in VS 2012 or are you starting with a new report? If you could attach a repro project to the connect bug that would help as well. Thanks!

    Matt M.


    This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, June 19, 2012 7:06 PM