locked
Enabling a computer to obtain a developer license without having to connect to the Internet

    Question

  • Hello.

    I have a question concerning the Windows store apps development license in offline scenario.

    I did read these articles:
    http://msdn.microsoft.com/en-us/library/windows/apps/hh974578.aspx#NoInternet
    http://technet.microsoft.com/en-us/library/hh852635.aspx

    I did execute the steps suggested under section "To configure your enterprise PCs with a developer license" in the second article and see the registry keys properly set on the windows 8.1 enterprise development station.

    The problem is that Visual Studio 2013 still requests me to go online and acquire Windows store apps developer license.

    Here is the question:
     Is there a way for developers who are always offline to create, run and debug Windows store apps with Visual Studio 2013?

    Best regards,
     Zverev Eugene


    Friday, January 17, 2014 7:54 PM

Answers

  • I know this is an old thread but I had the same issue and found the solution so I will post it for others to find.

    What I found is that there is a scheduled task that needs to run after a group policy update is changed.  It is schedule for something like every 6 hours (mine was every 6 days).  If your registry settings don't take effect right away this may be the problem.

    The scheduled task is Microsoft > Windows > WS > "License Validation"  Make sure its configured correctly and manually run it.

    You might have to log off and back on after this, not sure as I didn't have too.

    This solved my issue and is probably why yours worked after 48 hours

    Hope this helps someone anyone with the same issue.

    Wednesday, May 06, 2015 12:23 PM

All replies

  • Hi,

    Would you follow up To configure your enterprise PCs with a developer license to get developer license in this link:

    http://technet.microsoft.com/en-us/library/hh852635.aspx

    You can check the the link to make sure your device whether meets all of the sideloading requirements.

    See Configure PCs for Sideloading Requirements

    Best Wishes!


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey. Thanks<br/> MSDN Community Support<br/> <br/> Please remember to &quot;Mark as Answer&quot; the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Monday, January 20, 2014 5:42 AM
  • Hello.

    Did you even read the question? Did not I state that I already made the configuration mentioned in this very section and this does not help?

    Please read the question before you answer one.


    Monday, January 20, 2014 1:10 PM
  • Zverev - please describe the exact environment you are working in.  Is this is a domain-joined Windows 8/8.1 Enterprise machine or something else?

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Thursday, January 23, 2014 6:27 PM
    Moderator
  • Hi

    Domain joined windows 8.1 enterprise.

    There is Visual Studio 2013 enterprise with update 1 installed on target developer machines.
    I create a new Windows store project, Blank App for example, Visual studio shows a notification asking me to go online and obtain developer license. I can ignore the notification and make Visual Studio create the project anyway but I can not launch the project i.e. the notification for me to get developer license appears again and ignoring it stops the debugging process.

    After seeing this and reviewing the forums I found the article:
    http://technet.microsoft.com/en-us/library/hh852635.aspx
    and section "To configure your enterprise PCs with a developer license" in particular.

    I configured a GPO with flags
    Allow development of Windows Store apps without installing a developer license
    and
    Allow all trusted apps to install
    set to true.
    I can see the corresponding values in registry on target machines.

    Visual Studio keeps asking me to obtain developer license.

    I brought one of target machines online i.e. used it to flood forums with questions. The situation remained in this state for two days (about 48 hours).  After two days I can create the Windows store projects and the notification does not show up any more. I do not know what happened in between. All I can say is that I did not pass through the process of obtaining a developr license manually.

    Long story short: the mentioned GPO seems to do what it states but with a huge delay and it might depend on Internet connection availability on the target machine.

    Now I will go offline again and see what happens.

    Regards,
    Eugene.


    Friday, January 24, 2014 5:21 PM
  • Maybe it needed a GPUpdate.  Let us know what happens.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Friday, January 24, 2014 5:54 PM
    Moderator
  • No, it did not need gpupdate.

    As I said in my previous post, I checked that proper registry keys and values appeared on target machines before executing further tests.

    I mean these registry keys:
    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Appx\AllowDevelopmentWithoutDevLicense = 1
    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Appx\AllowAllTrustedApps = 1

    FYI I used gpupdate /force in order to speed up the process of GPO processing and even rebooted the target machines after the registry keys appeared to ensure that those are processed.

    Friday, January 24, 2014 6:32 PM
  • I know this is an old thread but I had the same issue and found the solution so I will post it for others to find.

    What I found is that there is a scheduled task that needs to run after a group policy update is changed.  It is schedule for something like every 6 hours (mine was every 6 days).  If your registry settings don't take effect right away this may be the problem.

    The scheduled task is Microsoft > Windows > WS > "License Validation"  Make sure its configured correctly and manually run it.

    You might have to log off and back on after this, not sure as I didn't have too.

    This solved my issue and is probably why yours worked after 48 hours

    Hope this helps someone anyone with the same issue.

    Wednesday, May 06, 2015 12:23 PM
  • Thanks for the information.  I did not know the root cause which you uncovered, but I found out that you can run a VS repair and it will likely run the License Validation task you've described.  Nice work. :-)

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Thursday, May 07, 2015 4:15 PM
    Moderator